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Help File Conventions
This Help File uses certain conventions when describing special events. The conventions used are:-

Hot Spots
In various topics within this Help File, graphics are used to show the visible appearance of an aspect 
of Smart Address. These graphics have areas called 'Hot Spots' which are areas within the graphic 
that may be clicked with the mouse to display information about that part of the graphic. The <Tab> 
key may also be used to "tab" to these Hot Spots.

Keyboard Interaction:-
Where keyboard interaction is possible, the keystrokes used will be indicated within < > markers. For
example:-

"<Ctrl> and <U>" means press the CTRL Key and the U Key at the same time.
"<Right Arrow> or <Up Arrow>" means press EITHER the Right Arrow Key or the Left Arrow Key.

Menu Interaction:-
When Menu Commands are referred to, they will be specified as "Menu Name | Menu Command", 
meaning the command required is to be found under the Menu Name given. For example:-

"File | Printer Setup" means the Printer Setup Command found under the File Menu
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Introduction
Smart Address has been designed as an easy to use and convenient Telephone and Address Book 
for your Windows Desktop. By having Smart Address always running, you will have your telephone 
numbers and addresses only a mouse click away.

Smart Address supports multiple Address Books open at any one time, with each Address Book 
being displayed in its own Window.

Some of the many facilities supported, include:-

· Keep notes with every entry.
· Group entries into user definable categories.
· Flexibility. Nearly all aspects of Smart Address are customizable by the user.
· Associate dates with entries. Smart Address will even remind you when a date is due. For 

example, Birthdays, Customer call required, etc.
· Export and Import entries to and from text files.
· Powerful Search and Indexing capabilities
· Inserts entries directly into your Word Processor
· Dials telephone numbers for you (Modem required)
· Powerful print facilities, supporting envelopes, address labels and lists.
· Automatic back-up of your Address Books
· Plus many more....
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General Information and Overview
This section provides general overview information about various aspects of Smart Address. For 
more information, please select the topic required:-

An Overview of Smart Address
How Smart Address Indexes Entries
Using the Tag Entry Facility
Printing with Smart Address
Importing Text Files to Smart Address
Using Reminders in Smart Address
Using the Auto-Dial Facility
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An Overview of Smart Address
Smart Address has been designed as an easy to use, yet powerful, Address Book Management 
application. Smart Address works by allowing multiple Address Books to be created to store differing 
sets of Addresses. Because Smart Address uses the Windows Multi-Document Interface (MDI), as 
many Address Books as the user wants, may be open at any one time.

Each Address Book is stored as a disk file and holds all the Address Information and 'personality' of 
that Address Book. The 'personality' is the customizable aspects of a Book, the labels used for data 
fields, which data fields are actually displayed, the Index Criteria for restricting entries displayed, etc. 
As disk files can be damaged or lost, and often users forget to back-up their files, Smart Address by 
default will always create a back-up copy of each    Book when it is closed. If there are then problems
with the disk file, Smart Address can use the back-up file and recreate the lost or damaged Book in 
full.

Smart Address has most facilities associated with Address Management available. There is a facility 
to Import Address Lists. that may have been created by other applications. into an Address Book and
also a facility to export entries from an Address Book. A use for which may be for example, to create 
a Mail Merge Data File for a Word Processor. There are various printing capabilities, allowing 
envelopes, labels or text listings to be produced for any range of Address entries.

An important facility within Smart Address is the Reminders function. This function allows dates to be
set for an entry and instruct Smart Address to remind you when that date becomes due. Smart 
Address can also automatically advance the set date by any period, once you have acknowledged it. 
This facility is designed to allow Birthdays, Customer Calls, etc. to be scheduled.

There are also very powerful search and index capabilities, allowing the user to be able to restrict the
entries displayed to their requirements and therefore be able to access whatever subset of 
information is needed.

Above all, Smart Address has been designed to be totally flexible and customizable. The user isn't 
forced to use the default design of an Address Book, their may amend the layout to suit their needs. 
In fact an Address Book doesn't even have to be used for Addresses. For example, the author has 
been using an Address Book to hold his Network Workstation hardware and configuration details. 
With the Search and Index capabilities, he has quick access to any of this information. Simply by 
changing the field labels and which fields are displayed, the whole concept of what an Address Book 
is used for can be altered.



How Smart Address Indexes Entries
Copyright © 1995 Oakley Data Services
Call +44 (0)1270 759739, Fax +44 (0)1270 765272, CIS 74774,1347

How Smart Address Indexes Entries
Smart Address requires each entry to have an Index. This Index is used to represent the entry within 
the "Index List" and is also used to restrict entries when an "Index Criteria" is set.

By default, each entry's Index Field will be set to <Default Index>. This Default Index is defined via 
the "Options | Preferences Command (Address Book Tab)" command and is unique to each Address 
Book. Changing the Address Book's Default Index, will re-index the whole of the Address Book.

For example, if the Address Book Default Index was set for the "Name" field, each entry's "Name" 
would appear in the Index List. Changing the default Index to say the "Company" field, would result 
in each entry's "Company" appearing in the Index List. In situations where the Default Index is 
changed to a field that is empty in an entry, Smart Address will attempt to Index that entry on the 
"Name" field and if that field is also empty, it will then Index it on the "Company" field. As the "Name" 
or "Company" field must be completed for each entry, Smart Address will always be able to assign a 
valid index to an entry.

This behavior can be changed by overriding the Index Field at entry level. Within each entry's data, a
value is held defining the field that is to be used for the Index. As detailed above, by default this is set
to the Address Books Default Index. By selecting a different field to use as the Index for an entry, the 
user may force that entry to always Index on that field, regardless of changes to the Address Books 
Default Index.
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Using the Tag Entry Facility
Whilst the Search and Index facilities of Smart Address allow the user to access various subsets of 
entries easily and quickly, there is sometimes a requirement to restrict a subset even more and 
without any logic to the restriction required.

To cater for these instances, Smart Address allows entries to be "Tagged". When an entry is 
"Tagged", that entry will be indicated in Red, within the Index List. Multiple entries can be tagged at 
any time and the Index List restricted to show just tagged entries or even just entries that are not 
tagged. Using this facility a new and non-logical subset of the Index List may be built.

Certain facilities within Smart Address can make use of the presence of tagged entries by allowing 
tagged entries to be specified as a range for processing. These include, Printing, Exporting and 
Deleting of Entries.

As an example for the use for tagging, take a situation where the user wishes to produce a selective 
Mail Merge file for their Word Processor. The selection he might require is all the entries that belong 
to a category of "Prospects" and that the user has phoned that day. While restricting the Index List to 
entries having a category of "Prospects" is easy, using the Index or Search commands, it isn't easy 
to restrict to entries he has contacted that day. By making use of the Tag facility, he can tag each 
entry as he contacts them and then produce the Mail Merge file using the tagged entries only.

It should be noted that tags are not saved within the Address Book. Tags are temporary flags that 
may be attached to any entry.
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Printing with Smart Address
Smart Address allows entries to be printed in various formats and supports the printing of Envelopes,
Address Labels and Text Listings.

Smart Address handles printing by allowing Print Styles to be defined that contain information as to 
what stationary the print will use, the layout of the fields on that stationary, the character fonts to be 
used and the fields that are to be printed. Smart Address also allows a Return Address and a logo to 
be printed on Envelopes and Address Labels.

Print Styles are grouped by the stationary type. For example, the Print Style of "Monarch Envelope" 
contains it's own unique definitions of layout, fonts and fields for printing. All of these definitions may 
be set-up via the "File | Printer Setup" command.

By default, Smart Address supports a large variety of common Envelope and Address Label formats, 
but user definable formats may be set-up using the two supplied "Custom" formats, or by the user 
creating their own new format. For information on creating a new format, see the Hints and Tips 
section of this Help File.

Smart Address, groups printing into two basic types, Envelope Printing and Label/Listing Printing. 
Each type may be associated with it's own Print Style and it's own Printer. This caters for users that 
may have a printer allocated for Address Labels and another for Envelopes, but the two types may 
use the same printer if required.

As mentioned above, Smart Address provides a basic facility for printing Text Listings. Text Listings 
allow entries to be printed in a format suitable, for example, for insertion into a "Filofax" or just as a 
simply text print. The Text Listing Print Style shares the same printer type as Address Labels and the 
output format for text listings may be defined via the "File | Printer Setup" command. Due to the 
varied differing formats of possible listings, Smart Address is only supplied with a couple of example 
Listing Styles.

It should be noted that when Smart Address prints Labels or Listings the output printed is 'clipped' to 
fit the output area defined. This means for example, that if the output is too long to fit on a defined 
label, Smart Address will only print the part of the line that fits on the label. This stops the next label 
being over-printed with the data from the previous label. If this facility is required to be turned off for 
some reason, see the Hints and Tips section of this Help File for the method to do this.
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Importing Text Files to Smart Address
Smart Address enables text files containing Address Entries, to be imported into an Address Book. In
order for these files to be imported, they need to be in a certain format and then mapped using the 
"File | Import" command to the various data fields within the Address Book.

The required format, is a format called "Comma Delimited" or "Comma Separated Values", CSV for 
short. This means that each Address Entry needs to start on a new line of the text file, with each data
field of that entry being separated by a certain character. Generally this character is a "," but Smart 
Address allows for other characters to be used. 

For example:-

"Mr.","A.N. Other",""","","Address Line 1","Address Line 2","Address ......

In the above example, the Address lines of the entry are represented by separated data fields for 
each line. This would require, when mapping the import fields using the "File | Import" command, 
each Address line to be mapped to it's associated Address line in the Address Book. Smart Address, 
also allows Address Lines to be imported that are represented as one data field. For example:-

"Mr.","A.N. Other","","","Address Line 1 <CR> Address Line 2 <CR> Address ...

In this example, the Address lines are separated by Carriage Returns, with the Address being 
represented as a single field. When mapping the import fields in this case, the Address field should 
only be mapped to the first Address line in the Address Book. Smart Address will automatically split 
this Address into the required separate lines.

If it is required to have quote ( " ) within a data field, then the quote should be duplicated, which 
instructs Smart Address that the quote is part of the data and not a field delimiter. For example:-

"Mr","A.N. Other","","","99 ""Riverview"" House","......

In this example, the first Address line will be imported as:    99 "Riverview" House

See Also:-
Using the Import Dialogue to Map Import Files.
Technical Specifications of the Import / Export File Format
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Import Dialogue
This dialogue allows the layout of the text file being imported, to be specified and mapped to the 
various data fields within the Address Book. The dialogue is presented as four Tab Pages which may 
be paged by clicking on the Tab Area.

For more information, click on the required element:-

See Also:-
General Information: Importing Text Files to Smart Address
Technical Specifications of the Import File Format
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Import / Export File Format
The file format rules used by Smart Address when importing and exporting files are as follows:-

· Each record starts on a new line and is terminated by a <Carriage Return> (#13) and <Line 
Feed> (#10) character.

· Each field within a record is enclosed in quotes ( " ) and is seperated by a comma ( , ). The 
comma may be replaced by another character using the "Options | Preferences" command.

· Quotes within a data field are duplicated. For example, "A House ""Name"" " would be imported 
as: A House "Name"

· Line breaks within the Notes field should be represented by a single <Carriage Return> (#13) 
character.

Note: #?? refers to the ASCII character code.
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Using Date Reminders in Smart Address
An important part of Smart Address is the Reminders facility. This facility allows dates to be set for an
entry and have Smart Address, remind you when those dates become due. The amount of advance 
warning that Smart Address gives you, can be configured by the user. By default, Smart Address will 
use two days advance warning.

Lets use the following example, to explain the use of Date Reminders:-

The user has configured one of the three date fields to use as a Birthday field and has entered the 
date of a Birthday. By default, Smart Address will not take any action for this date, as the default 
reminder is that of "No Reminder". However, as the field is being used for Birthdays, the user has set
the reminder to "Yearly Reminder", as Birthdays are yearly events.

Smart Address then constantly checks the date of this entry against the current date . When the date 
is approaching and falls within the defined advance warning period, Smart Address will indicate that 
the date is becoming due, by placing a Yellow "Warning" indicator next to the date concerned and 
next to the entry in the Index List. The user can then send a Birthday card to the person concerned 
and then acknowledge the reminder using the "Tools | Acknowledge Reminder" command. As the 
reminder was set as "Yearly Reminder", Smart Address will then automatically advance the date by 
one year, so that the user will be reminded to send another Birthday card next year.

If the user hadn't acknowledged the reminder, then Smart Address would take no further action until 
the Birthday matched the current day. Smart Address would then replace the Warning indicator with a
Green "Due Today" indicator, indicating that there is an action due today for that entry. If the user still 
did not acknowledge the reminder, then when the Birthday was past, Smart Address would replace 
the "Due Today" indicator with a Red "Entry Overdue" indicator. This Overdue indicator will remain 
until the user acknowledges it.
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Using the Auto-Dial Facility
Smart Address has a built in Automatic Dialing facility, that allows a telephone number contained 
within an Address Book to be dialed. It should be noted, that to use this facility a Modem is required 
to be attached to the computer.

Auto-Dial has a facility that can be configured so that prefixes may be added to telephone numbers. 
This allows situations where it may be necessary to first dial a number to obtain an outside line, or to 
select a different telephone service provider, to be catered for. It also caters for internal telephone 
extensions to be automatically recognized. For example, if the user has set a prefix up to be added 
to all dialed numbers to select an outside line, this prefix wouldn't be required when dialing an 
internal extension. By making use of the automatic identification of extensions, this is based on the 
length of the number being dialed, Smart Address will know not to add the outside line prefix.

Also built into the Auto-Dial facility, is a re-dial function. This function allows Smart Address to be 
configured to automatically re-dial a telephone number if that number is found to be busy when it's 
dialed. Smart Address will continue to dial the number, until either it rings or is canceled by the user.
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Click on the required element for more detail...
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Hints and Tips
This section provides hints and tips on various aspects of Smart Address. For more information, 
please select the topic required:-

Automatic Recovery of Corrupt Address Books
Adding a New Word Processor to Smart Address
Adding a New Envelope, Label or Listing Style to Smart Address
Converting Old Version Address Books
Copying a Field to and from the Windows Clipboard
Creating Address Book Icons on your Desktop
Creating a Mail Merge file for Microsoft's Word for Windows
Invoking Smart Address from your Word Processor
Inserting Empty Fields to a Word Processor
Invoking the Display Index Dialogue Quickly
Locking and Unlocking a Print Style Layout
Networking Address Books
Relocating the Smart Address Configuration File
Restrictions with Importing Records
Securing your Smart Address Files
SMARTADR.CFG Lost or Corrupt
Tagging Entries using the Mouse.
Turning off Confirmation Prompts
Turning off Print Clipping
Using Fast Edit
Quickly Resetting the Display Index to All Entries
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Automatic Recovery of Corrupt Address Books
If Smart Address attempts to open an Address Book that has become damaged or could not be 
located (maybe it's been deleted, or moved), Smart Address will display a message informing the 
user of this problem.

If Smart Address detects that a back-up copy exists for the Address Book concerned, Smart Address 
will offer to automatically recover the Address Book from it's back-up copy. If this action is taken, 
Smart Address will rebuild the Address Book and open it.

If no back-up copy is detected, then Smart Address will terminate the Open request.

By default, Smart Address automatically creates a back-up copy of an Address Book when that Book 
is closed. The back-up copy is saved to the same disk location as the original Address Book. This 
automatic back-up, can be disabled by the user using the "Options | Preferences" command.    It 
should be noted however, that if the back-up facility is disabled, then Smart Address will not be able 
to automatically recovery any lost or corrupt Books. Due to this, the automatic back-up should only 
be disabled, if the user performs his own back-up processes.

See Also:-
Preferences Command
Securing your Smart Address Files
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Preferences Command
On issuing this command via the Options Menu, Smart Address will display the Preferences 
dialogue. This dialogue allows various settings within Smart Address to be configured by the user.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Preferences Dialogue
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Preferences Dialogue
This dialogue allows various settings within Smart Address to be configured by the user. The 
dialogue is presented as three Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the general settings to be configured. For more information, click on the required 
element:-

See Also:-
Preferences Dialogue (Save/Confirm Tab)
Preferences Dialogue (Address Book Tab)
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Preferences Dialogue
This dialogue allows various settings within Smart Address to be configured by the user. The 
dialogue is presented as three Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the settings related to Saving and Confirmations to be configured. For more 
information, click on the required element:-

See Also:-
Preferences Dialogue (General Tab)
Preferences Dialogue (Address Book Tab)
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Preferences Dialogue
This dialogue allows various settings within Smart Address to be configured by the user. The 
dialogue is presented as three Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the settings unique to each Address Book to be configured. For more information, 
click on the required element:-

See Also:-
Preferences Dialogue (General Tab)
Preferences Dialogue (Save/Confirm Tab)
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Securing your Smart Address Files
Whilst Smart Address provides an automatic back-up facility for backing up your Address Books 
when they are closed, you should still take your own security of your Address Books. The main 
reason for this being that the automatic back-ups are saved to the same physical location on your 
disk as your original Address Books. If that directory on you disk was to be deleted or lost, then you 
would also loose your back-up Books as well as your original Books.

It is therefore recommended that your add your Address Books and the changeable files within Smart
Address to your regular disk security. The files that should be backed up are :-

Address Books
Any file with the extension .ADR

Smart Address Configuration Files
SMARTADR.CFG (This will be in the Smart Address Directory)
SMARTADR.INI (This will be in your Windows Directory)
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Adding a New Word Processor to Smart Address
In order for Smart Address to allow a Word Processor to be defined, it needs to know certain 
information about that Word Processor. By default, Smart Address is supplied with a selection of 
common Word Processors already defined. It may be however, that the Word Processor that you 
use, is not defined.

The following describes how you can define a new Word Processor to Smart Address:-

You should always back-up SMARTADR.CFG before editing it. Failure to do so can cause 
problems running Smart Address if the file should become damaged.

1 Using Microsoft Write or another such editor, open the SMARTADR.CFG file that resides in the 
same directory as SMARTADR.EXE (the Smart Address Program)

2 Locate the section [Word Processors]
3 Insert a line within this section for the Word Processor you wish to use. The format of this line 

is :-

Word_Processor_Name=Caption_Bar

Where:-

Word_Processor_Name is the name you wish to use to reference the Word Processor, using 
Smart Address.

Caption_Bar is the caption title for the Word Processors main window. The Word Processor 
should not have documents currently open when you check the caption title.

4 Exit Write, or the editor used, first saving the modified file.
5 Exit and Restart Smart Address and select the new Word Processor using the "Options | 

Configure Word Processor" command.
If after defining the new Word Processor, Smart Address will not insert the entry to it, check that you 
specified the correct Caption_Bar as without this, Smart Address is unable to locate the application 
required.
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Adding a New Envelope, Label or Listing Style
Smart Address is supplied with a large selection of pre-defined Envelope, Address Labels and a few 
Text Listing Styles. It may be however, that you will wish to define your own Style in addition to using 
the supplied "Custom" Styles available.

The following describes how you can define a new Print Style to Smart Address:-

You should always back-up SMARTADR.CFG before editing it. Failure to do so can cause 
problems running Smart Address if the file should become damaged.

1 Using Microsoft Write or another such editor, open the SMARTADR.CFG file that resides in the 
same directory as SMARTADR.EXE (the Smart Address Program)

2 Locate the section [Styles]
3 Insert a line within this section for the Print Style you wish to define. The format of this line is :-

Style_Description=Style_Id

Where:-

Style_Description is a description of the new Print Style.

Style_Id is either 11 for an Envelope Style, 12 for a Label Style or 13 for a Listing Style
4 Exit Write, or the editor used, first saving the modified file.
5 Exit and Restart Smart Address and configure the New print Style using the "File | Printer Setup" 

command.
It is important to ensure the new Print Style is configured before using as various settings relating to 
the Style layout need defining via the Printer Setup command.
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Converting Old Version Address Books
With Version 2.0, the file format of Address Books changed to cater for the increased amount of 
information each Address Book now holds. Smart Address will automatically offer a conversion of 
any previous version's Address Book that is opened.

Alternatively, you may elect to only open the old Address Book as Read Only. In this case, Smart 
Address will not convert the Book to the new file format, but as a result will only allow the Address 
Book to be read and not updated.

See Also:-
Convert Address Book Dialogue
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Convert Address Book Dialogue
This dialogue will be displayed when the user attempts to open an Address Book created with an 
older version of Smart Address. It allows the Address Book concerned to be converted to the new file
format if required. For more information, click on the required element:-

See Also:-
Hints and Tips: Converting Old Version Address Books



Copying A Field to and from the Windows Clipboard
Copyright © 1995 Oakley Data Services
Call +44 (0)1270 759739, Fax +44 (0)1270 765272, CIS 74774,1347

Copying A Field to and from the Windows Clipboard
Whilst Smart Address provides a command to copy a complete entry to the Clipboard and a 
command to Paste a complete entry from the Clipboard to an entry, you can also copy a single field, 
or part of a field, to and from the Windows Clipboard.

Copying a Field to the Clipboard
In order to copy a field to the Windows Clipboard, highlight the text within the field to be copied, using
the mouse or <Shift> and <Cursor Keys>, and then press <Ctrl> and <C>. The highlighted text will 
then be copied to the Clipboard.

Copying Text from the Clipboard to a Field
Position the cursor in the field to receive the text and at the location within the field you wish the text 
to go and the press <Ctrl> and <V>. The text on the Clipboard will then be inserted into the field 
selected.
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Creating Address Book Icons on Your Desktop
Address Books produced by Smart Address are automatically associated with Smart Address. This 
means that Smart Address can be started and an Address Book opened by simply double-clicking on
the Address Book in Windows File Manger, or by entering the Address Book name, including its Path,
at Program Managers "File | Run" Command.

This also allows Icons to be set-up within a Group in Program Manager. Once an Icon is set-up, 
double-clicking on the Icon will open the associated Address Book for you.

The quickest way to create an Icon for an Address Book, is to open File Manager and Program 
Manager so they are both visible. Using File Manager, locate one of your Address Books. Click once 
on the Address Book and without releasing the mouse button, 'drag' the Address Book out of File 
Manager and 'drop' it on one of Program Managers Icon Groups.

Double-clicking of this new Icon, will open the Address Book that was 'dragged'.

For more information on creating Icons on your Desktop, please consult your Windows 
documentation.
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Creating a Mail Merge File for Word for Windows
Smart Address can via use of the "File | Export" Command produce Mail Merge Data Files for input 
to a Word Processor. As an example, the following describes how to produce a Mail Merge file for 
Microsoft's Word for Windows Version 6.0:-

1 Restrict the Index List in Smart Address to the entries required for the Mail Merge.
2 Use the "File | Export" command and it's ALL Button to export the Complete Index List to a file 

called MAILDATA.TXT.
3 Start Word for Windows and select the "Tools | Mail Merge" command
4 Follow the screen prompts and select the Data Source as Open Data Source, and open the 

MAILDATA.TXT file which was exported in 2 above.
5 Create Mail Merge fields within your Main Document and then Merge the Data File using the 

Merge command.
Most Word Processors can use Mail Merge files as Word for Windows does. For more information, 
please consult the documentation for your Word Processor.
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Invoking Smart Address from your Word Processor
By making use of the Macro facilities with your Word Processor, it is possible to add a command in 
your Word Processor that invokes Smart Address. This allows for you to then call Smart Address 
while editing a document, select the entry required and have Smart Address insert that entry into the 
document and then returning control back to the Word Processor.

As an example of this, Smart Address comes with a Word for Windows Macro that adds the facility to
invoke Smart Address to the Tools Menu. In order to run this macro, open the SMARTMAC.DOC file, 
located in the same directory as you installed Smart Address, using Word for Windows and run the 
Macro InstallSmartAddress.

For more information, please consult the documentation for your Word Processor.
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Inserting Empty Fields to a Word Processor
By default, Smart Address ignores fields that are empty when inserting a record to a Word Processor.
By amending the SMARTADR.INI file, Smart Address can be instructed to insert empty fields as well.

The following describes how to make this amendment:-

You should always back-up SMARTADR.INI before editing it. Failure to do so can cause 
problems running Smart Address if the file should become damaged.

1 Using Microsoft Write or another such editor, open the SMARTADR.INI file that resides in the 
Windows directory.

2 Locate the section [General]
3 Insert the following line within this section:-

Keep Blanks=1

This instructs Smart Address to include empty fields during inserts to Word Processors. To ignore
empty fields, with remove this line or change its value to 0

4 Exit Write, or the editor used, first saving the modified file.
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Invoking the Display Index Quickly
The Set Display Index command may be invoked either via the "Tools | Set Display Index" command 
or via the Toolbar Button.

A shortcut is also available to invoke this command, by simply clicking the right mouse button while 
the mouse is over the Address Book.

See Also:-
Set Display Index Dialogue
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Set Display Index Dialogue
This dialogue allows the Index Criteria to restrict the entries displayed within the Index List to be 
specified. For more information, click on the required element:-

See Also:-
General Information: Indexing Entries
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Locking and Unlocking a Print Style Layout
Smart Address by default, locks the Print Style Layouts of all the supplied Print Styles. This is due to 
the fact that these Styles are pre-defined and therefore the dimensions should not need to be 
changed.

If for some reason, you need to 'unlock' these styles or possibly 'lock' some of your own styles, then 
the following can be actioned:-

You should always back-up SMARTADR.CFG before editing it. Failure to do so can cause 
problems running Smart Address if the file should become damaged.

1 Using Microsoft Write or another such editor, open the SMARTADR.CFG file that resides in the 
same directory as SMARTADR.EXE (the Smart Address Program)

2 Locate the section [xxx] - where xxx is the Style Name to be locked / unlocked.
3 If locking the Style add the following line into this section:-

Locked=1

If unlocking the Style, remove the following line from this section:-
Locked=1

4 Exit Write, or the editor used, first saving the modified file.
5 Exit and Restart Smart Address.
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Networking Address Books
Smart Address supports the sharing of Address Books over a Network.

In order to share an Address Book, the Address Book should be located on the Network so all uses 
have access to it. The Network File Permissions should then be set so that only one person has 
update access to that Book, with everyone else having Read-Only access. The person with update 
access, acts as the maintainer of the Address Book and is responsible for updates to that Book.

Currently Smart Address does not support multi-user update access to an Address Book.

Smart Address can also be installed to be run from a Network. To do this, install Smart Address to a 
location on the Network all users have access to and then set the Network File Permissions to Read-
Only for the Smart Address directory.

Multiple Copy Licenses
It should be remembered that registration of a single copy of Smart Address allows you to use it on a 
single PC, and to make back-up copies for security purposes. It does not permit installation on more 
than 1 PC at the same time, or use on multiple workstations connected to a network.

However, we do offer extremely attractive discounts for multiple-copy licenses, allowing you to make 
Smart Address an integral part of your network, site or corporation. Please contact us for details.

See Also:-
Relocating the SMARTADR.CFG File
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Relocating the Smart Address Configuration File
Smart Address holds all of it's defined Printer Styles within a configuration file called 
SMARTADR.CFG. This file, by default, resides in the same location as the Smart Address program 
file SMARTADR.EXE.

If there is a requirement for this file to be located in another location, e.g. to allow individual users to 
reconfigure the print styles when running Smart Address over a Network, then a entry may be placed
within the SMARTADR.INI file located in the Windows directory.

The following describes how to make this amendment:-

You should always back-up SMARTADR.INI before editing it. Failure to do so can cause 
problems running Smart Address if the file should become damaged.

1 Using Microsoft Write or another such editor, open the SMARTADR.INI file that resides in the 
Windows directory.

2 Locate the section [General]
3 Insert the following line within this section:-

CFG File=C:\WINDOWS\SMARTADR.CFG

In this example, Smart Address will look for the configuration file in the C:\WINDOWS directory. 
To locate the file in another location, simply change the drive and directory path as required.

4 Exit Write, or the editor used, first saving the modified file.
5 Exit Smart Address and using File Manager copy the configuration file from it's current location to

the location now specified within the INI file.
6 Restart Smart Address
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SMARTADR.CFG Lost or Corrupt
Certain functions within Smart Address required access to the Smart Address Configuration file, 
SMARTADR.CFG, which is located in the same directory as the Smart Address program file 
(SMARTADR.EXE).

If this file should become damaged or lost, then certain functionality of Smart Address will not be 
available. This situation will be notified by an appropriate message when trying to perform one of 
these functions.

To correct this, the configuration file should be recovered from your last good back-up and Smart 
Address restarted. If for some reason you did not have a back-up, then you should reinstall Smart 
Address from it's original disk.

See Also:-
Securing your Smart Address Files.
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Tagging Entries with the Mouse
Whilst Smart Address enables entries to be "Tagged" via use of the "Tools | Tag Entry" command and
the Keyboard Shortcut of <Ctrl> and <T>, you can also "Tag" an entry by double-clicking it with the 
mouse.

Double-clicking an entry that is already "Tagged", will remove the tag state from that entry.



Turning off Confirmation Prompts
Copyright © 1995 Oakley Data Services
Call +44 (0)1270 759739, Fax +44 (0)1270 765272, CIS 74774,1347

Turning off Confirmation Prompts
Smart Address by default provides confirmation prompts for various actions, including deletions, 
acknowledgment reminders, unknown categories, etc.

Any of these confirmation prompts may be turned off by use of the "Options | Preferences" 
command.

Warning: If you have turned off a confirmation prompt, remember you will have no confirmation when
performing that action. For example, no confirmation when deleting a range of entries.

See Also:-
Preferences Command
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Turning off Print Clipping
When Smart Address prints Labels or Listings the output printed is 'clipped' to fit the output area 
defined. This means for example, that if the output is too long to fit on a defined label, Smart Address
will only print the part of the line that fits on the label. This stops the next label being over-printed with
the data from the previous label. 

If this facility is required to be turned off for some reason the following should be actioned:-

You should always back-up SMARTADR.INI before editing it. Failure to do so can cause 
problems running Smart Address if the file should become damaged.

1 Using Microsoft Write or another such editor, open the SMARTADR.INI file that resides in your 
WINDOWS directory, usually this is C:\WINDOWS

2 Locate the section [General]
3 Add the following line to this section, or amend the line if already present:-

NoClipping=1

If you wish to reinstate Print Clipping them just remove the above line from this section.
4 Exit Write, or the editor used, first saving the modified file.
5 Exit and Restart Smart Address
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Using Fast Edit
The "Fast Edit" facility of Smart Address allows Update Entry Mode to be entered simply by clicking 
the left mouse button in any field within the "Data Page" or tabbing into the "Data Page" by use of the
<Tab> key.

If the Index List is empty, i.e. the is no currently selected entry, the "Fast Edit" facility will invoke New 
Entry Mode when used, allowing an entry to be added to the Address Book.

This facility may be turned off if required by use of the "Options | Preferences" command.
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Reset Display Index
On issuing this command via the Toolbar Button, Smart Address will reset the Index Criteria to 
display all entries and removes any Search or Show Commands that may have been in effect.

The Index Criteria controls the entries that are displayed within the Index List, except when a Show 
Command or Search is in effect.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Setting the Display Index
Searching an Address Book
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Set Display Index
On issuing this command, either via the Tools Menu, Toolbar Button or the Keyboard Shortcut, Smart
Address will display the Display Index dialogue. This dialogue allows the current Index Criteria to be 
set.

The Index Criteria controls the entries that are displayed within the Index List, except when a Show 
Command or Search is in effect.

Keyboard Shortcut:-
<F9>

Toolbar Button:-

See Also:-
Display Index Dialogue
Searching an Address Book
Hints and Tips: Invoking the Display Index Dialogue Quickly
Hints and Tips: Quickly Resetting the Display Index to All Entries
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Search Address Book
On issuing this command, either via the Tools Menu, Toolbar Button or the Keyboard Shortcut, Smart
Address will display the Search Dialogue allowing the required search parameters to be entered.

Once the search parameters have been entered, Smart Address will search the current Address 
Book for any entries that match those parameters. If no match is found, Smart Address will indicate 
this with a "No Entries Found" message.

If there are matched entries in the Address Book, Smart Address displays these entries within the 
Index List and updates the Status Bar accordingly, to reflect the search in effect and the number of 
entries found.

Note: This Search will stay in effect, until either another Search is performed, the Display Index reset 
or one of the Show... commands issued.

Caution: Any updates made while a search is effect, will be subject to that search. For example, if a 
new entry is added that does not match the current search parameters, then that entry will not 
appear in the Index List.

Keyboard Shortcut:-
<F3>

Toolbar Button:-

See Also:-
Search Dialogue
Setting the Display Index
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Search Dialogue
This dialogue allows a search to be performed against the current Address Book. For more 
information, click on the required element:-
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This product is Shareware. Shareware is a form of software distribution, not free software. If you 
have not already registered this product, you have the right to evaluate it for a period of 30 days from
the date you initially install it. If you find that it suits your needs and you wish to continue to use it 
after the 30 day period you are required to register it by paying the registration fee to Oakley Data 
Services. There are significant advantages to registering your copy, not least the continued 
availability of good quality software at reasonable prices. 

You also have the right, and in fact you are actively encouraged, to distribute copies of the 
Shareware version of this product. You may assume you have our authority to distribute this product 
unless we explicitly tell you otherwise. It must, however remain in its original, unmodified state, and 
all its constituent files must be included. No-one may charge for the program itself, although a 
reasonable fee for the media used and copying costs is allowable.

You may not distribute copies of the registered version of this product. You may not 
distribute the SMTADR2X.DLL file in any form.

This software is supplied as is without warranty or representation either express or implied with 
respect to the program or its documentation including their quality, performance, merchantability, or 
fitness for a particular purpose. 

In no event with Oakley Data Services or any of its agents or assigns, or any organization distributing
Smart Address on its behalf be liable for direct, indirect, special, incidental, or consequential 
damages arising out of the use of, or inability to use the program. 

All trademarks are acknowledged.
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You can register your copy of Smart Address by Phone, Fax, Mail or E-Mail. We accept cheques in 
Sterling, or VISA, Mastercard or American Express. If you have a CompuServe account you can also
register via the SWREG service. Smart Address's SWREG product ID is 4521 and the price via this 
mechanism is currently 39 US Dollars.

Printing an Order Form
You can access an order form if you wish to register by Fax, Mail or E-Mail by pressing the 'Order 
Form' button on the reminder screen, or via "Help | Order Smart Address". The order form shows the 
current registration fees and addresses and phone numbers.

Multiple Copy Licenses
Registration of a single copy of Smart Address allows you to use it on a single PC, and to make 
back-up copies for security purposes. It does not permit installation on more than 1 PC at the same 
time, or use on multiple workstations connected to a network.

However, we do offer extremely attractive discounts for multiple-copy licenses, allowing you to make 
Smart Address an integral part of your network, site or corporation. Please contact us for details.

Please let us know which version you have
If you register by phone, please let us know which version of the program you currently have (shown 
by "Help | About Smart Address"). This helps us greatly to determine how effective our shareware 
distribution methods are. If you use the order form the version number is already pre-printed on it.
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Upgrade Policy
The code (.EXE file) for the registered and unregistered versions of the program are identical, and it 
is the presence of a file SMTADR2X.DLL that is supplied with the registered version that causes the 
program to behave in a registered fashion. The presence of the DLL will also cause any further 
versions of Smart Address that still bear the 2.x release number to behave as registered versions, 
wherever you obtain them from. Versions that bear the 2.x release number will generally be for minor
enhancements and bug-fixes. Any release containing major new functionality will bear the release 
number 3.x, and an upgrade fee will probably be chargeable.

We will make new versions of Smart Address available via the usual sources, online on services 
such as CompuServe, CIX, the Internet and via disk vendors, cover disks and CD's.

We have three prime locations for new releases and support. These are:-

CompuServe: Section 4 of the UKSHARE forum. The latest versions of all our products are available 
in Library    4.

CIX: Join the oakley conference.

The Internet: Via our World Wide Web Server at http://198.49.174.129

If you do acquire a newer version of Smart Address simply ensure that the SMTADR2X.DLL file you 
got when you registered is either in the directory that the Smart Address program (SMARTADR.EXE)
is in, or is in your WINDOWS directory.

Getting Support
Before you reach for the phone, please make sure you have looked through this Help File 
first. If you have a question that this Help File doesn't answer, or are reporting what appears 
to be a bug then we will be pleased to hear from you. But if it is a question that is answered in
this Help file then all we will do is point you to the relevant section, and you will just get an 
answer a little bit slower. This is not meant to be awkward, but we try to keep our costs down 
to allow us to produce this high quality software at value-for-money prices, and answering 
support calls is an expensive undertaking. After all, some of the major software companies 
either charge for support or provide it on premium-price phone numbers. We don't want to 
have to do that.

For support, please contact the agent who sold you the software. For contact information please 
refer to the order form.

This product is authored by:-

Oakley Data Services,



3, Oakley Close,
Sandbach,
Cheshire CW11 9RQ
England.

Phone: (+44) (0)1270 759739      Fax: (+44) (0)1270 765272

CIS E-Mail: 74774,1347
Internet: 74774.1347@compuserve.com

Or contact us via our support section on CompuServe, Section 4 of the UKSHARE forum or via our 
Internet Word Wide Web Server at http://198.49.174.129, or on CIX in the oakley conference.
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Set Access Privileges Command
This command allows the Access Privileges for an Address Book to be defined, allowing control over 
the Address Book functionality available to users.

Note: This command will only be available when using the customized version of Smart Address that 
supports Address Book Encryption. For more details on this version, please contact your supplier

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Encrypting an Address Book
Set Access Privileges Dialogue
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Encrypt Address Book Command
On issuing this command via the Edit Menu, Smart Address will Encrypt the current Address Book, 
using the Supplier Key supplied with the Encryption version of Smart Address.

When a Address Book is encrypted, a checkmark will be placed next to the Encrypt command to 
indicate that the Address Book is currently encrypted. To revert the Address Book to a non-encrypted
state, just select the Encrypt command again, thus removing the checkmark from the command.

Note: This command will only be available when using the customized version of Smart Address that 
supports Address Book Encryption. For more details on this version, please contact your supplier.

Warning: An Address Book that is encrypted, can only be accessed by a user that has been given the
required Supplier Key. Without this Key, access to the Address Book will not be possible.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Setting Access Permissions for an Address Book
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Set Access Privileges Dialogue
This dialogue allows the access privileges of an Address Book to be set. The access privileges 
control what level of access a user has to functionality within an Address Book. For more information,
click on the required element:-

Note:-
This dialogue will only be available when using the customized version of Smart Address that 
supports Address Book Encryption. For more details on this version, please contact your supplier.
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Acknowledge Reminder Command
On issuing this command, either via the Tools Menu or Toolbar Button, Smart Address will allow the 
"Active Reminder" for the currently selected entry to be acknowledged.

If the currently selected entry doesn't have an Active Reminder, then this command will not be 
available.

When acknowledging an Active Reminder, Smart Address will display a dialogue box requesting 
confirmation of the acknowledgment. Once acknowledged, Smart Address will advance the 
associated date, by the period identified by the Reminder set. 

For example:-
 "4 Weekly Reminder" would advance the associated date by 28 days.
 "Remind Once Only" would not advance the date, but would change the Reminder to "No 
Reminder".

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Confirm Reminders Acknowledgment Dialogue
Hints and Tips: Show only Entries with Active Reminders
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Confirm Acknowledgment of Reminders Dialogue
This dialogue allows confirmation before acknowledging a reminder and advancing it's date or 
resetting the reminder. For more information, click on the required element:-

See Also:-
General Information: Using Reminders in Smart Address
Hints and Tips: Turning off Confirmations
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Show Active Reminders
On turning on this command, either via the Tools Menu or Toolbar Button, Smart Address will only 
display entries that have an "Active Reminder" set against them. The Info Area of the Status Bar will 
also be updated, to reflect that the Index List is currently restricted to Active Reminders Only. 

If an entry's reminder is "Acknowledged" then the entry looses it's Active Reminder state and will 
therefore be automatically removed from the Index List.

This command acts as a toggle and so selecting it again will turn off the showing of Active reminders 
and reset the Index List. 

Note: The restricting of the Index List to Active Reminders only, can also be turned off by resetting 
the Display Index, performing an Address Search or by issuing another one of the Show Commands.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Acknowledging Reminders
Setting the Display Index
Searching an Address Book
General Information: Using Reminders in Smart Address
Hints and Tips: Quickly Resetting the Display Index to All Entries
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Add New Entry to Address Book
On issuing this command, either via the Edit Menu, Toolbar Button or Keyboard Shortcut, Smart 
Address will place the current Address Book into New Entry Mode and clear the "Data Page"

Keyboard Shortcut:-
<Ctrl> and <A>

Toolbar Button:-

See Also:-
Applying the Addition to the Address Book
Canceling the Addition to the Address Book
Hints and Tips: Using Fast Edit to Invoke the New Command
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Update Entry in Address Book
On issuing this command, either via the Edit Menu, Toolbar Button or Keyboard Shortcut, Smart 
Address will place the current Address Book into Update Entry Mode and the "Data Page" enabled 
for editing.

Keyboard Shortcut:-
<Ctrl> and <U>

Toolbar Button:-

See Also:-
Applying the Update to the Address Book
Canceling the Update to the Address Book
Hints and Tips: Using Fast Edit to Invoke the Update Command
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Apply Addition/Update to Address Book
On issuing this command, either via the Edit Menu, Toolbar Button or Keyboard Shortcut, Smart 
Address will apply the data within the "Data Page", to the current Address Book entry. If the Address 
Book was in New Entry Mode, then Smart Address will first create an new entry, before applying the 
data.

In order for data to be applied the Category field and either the Name field or Company field have to 
be completed. It should be noted that the user may have customized the Address Book, so that these
fields may be labeled differently.

Keyboard Shortcut:-
<Ctrl> and <Enter>

Toolbar Button:-

See Also:-
Canceling an Addition/Update to the Address Book
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Cancel Addition/Update
On issuing this command, either via the Edit Menu, Toolbar Button or Keyboard Shortcut, Smart 
Address will cancel any Addition or Update that was in progress for the current Address Book.

The data within the "Data Page" will be restored to it's previous value.

Keyboard Shortcut:-
<Esc>

Toolbar Button:-

See Also:-
Applying an Addition/Update to the Address Book
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Address Page Command
On issuing this command, either via the View Menu, keyboard shortcut or via the "Address Tab", 
Smart Address will switch the "Data Page" display to the Address Page.

Keyboard Shortcut:-
<F5>

Toolbar Button:-
Use the "Address Tab"

See Also:-
Address Data Page
Notes Page Command
Reminders Page Command
Others Page Command
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The Address Tab
This page, or 'tab', is used to present the Address information for the currently selected entry. By 
default, the 'tab' will contain the fields as detailed below. It should be noted that as the field labels 
and the fields displayed are customizable by the user, the actual fields presented within an Address 
Book may vary:-

Click on the required element for more detail...

See Also:-
Customizing the Field Labels
Customizing the Fields Displayed
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Set Field Labels Command
On issuing this command via the Options Menu, Smart Address will display the Set Field Labels 
dialogue allowing the field labels of the current Address Book to be defined by the user.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Set Field Labels Dialogue
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Set Field Labels Fields Dialogue
This dialogue allows a user to define the field labels to be used for the current Address Book. For 
more information, click on the required element:-
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Show Fields Command
On issuing this command via the Options Menu, Smart Address will display the Show Fields dialogue
allowing the user to define which fields are visible within an Address Book.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Show Fields Dialogue
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Show Fields Dialogue
This dialogue allows a user to define the fields that will be displayed in the current Address Book. For
more information, click on the required element:-
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Notes Page Command
On issuing this command, either via the View Menu, keyboard shortcut or via the "Notes Tab", Smart 
Address will switch the "Data Page" display to the Notes Page.

Keyboard Shortcut:-
<F6>

Toolbar Button:-
Use the "Notes" Tab

See Also:-
Notes Data Page
Address Page Command
Reminders Page Command
Others Page Command
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The Notes Tab
This page, or 'tab', is used to present any Notes made for the currently selected entry. By default, the
'tab' will contain the fields as detailed below. It should be noted that as the field labels and the fields 
displayed are customizable by the user, the actual fields presented within an Address Book may 
vary:-

Click on the required element for more detail...

See Also:-
Customizing the Field Labels
Customizing the Fields Displayed
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Reminders Page Command
On issuing this command, either via the View Menu, keyboard shortcut or via the "Reminders Tab", 
Smart Address will switch the "Data Page" display to the Reminders Page.

Keyboard Shortcut:-
<F7>

Toolbar Button:-
Use the "Reminders Tab"

See Also:-
Reminders Data Page
Address Page Command
Notes Page Command
Others Page Command
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The Reminders Tab
This page, or 'tab', is used to present any dates that have been set for the currently selected entry. 
By default, the 'tab' will contain the fields as detailed below. It should be noted that as the field labels 
and the fields displayed are customizable by the user, the actual fields presented within an Address 
Book may vary:-

Click on the required element for more detail...

See Also:-
Customizing the Field Labels
Customizing the Fields Displayed
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Others Page Command
On issuing this command, either via the View Menu, keyboard shortcut or via the "Others Tab", Smart
Address will switch the "Data Page" display to the Others Page.

Keyboard Shortcut:-
<F8>

Toolbar Button:-
Use the "Others Tab"

See Also:-
Others Date Page
Address Page Command
Notes Page Command
Reminders Page Command
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The Others Tab
This page, or 'tab', is used to present the any other information that is related to the currently 
selected entry. By default, the 'tab' will contain the fields as detailed below. It should be noted that as 
the field labels and the fields displayed are customizable by the user, the actual fields presented 
within an Address Book may vary:-

Click on the required element for more detail...

See Also:-
Customizing the Field Labels
Customizing the Field Displayed



Window Arrange Icons Command
Copyright © 1995 Oakley Data Services
Call +44 (0)1270 759739, Fax +44 (0)1270 765272, CIS 74774,1347

Window Arrange Icons Command
On issuing this command, via the Window Menu, Smart Address will arrange any minimized Address 
Book Icons.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Window Cascade Command
Window Tile Command
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Window Cascade Command
On issuing this command via the Window Menu, Smart Address will arrange all Address Books by 
cascading them within the Smart Address application window.

Keyboard Shortcut:-
None

Toolbar Button:-
None.

See Also:-
Window Tile Command
Window Arrange Icons Command
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Window Tile Command
On issuing this command, via the Window Menu, Smart Address will arrange all Address Books by 
tiling them within the Smart Address application window.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Window Cascade Command
Window Arrange Icons Command
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Active Address Books List
Maintained within the Window menu, is a list of the currently opened Address Books. Selecting any 
one of these Address Books from the list, will select it.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.
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Clear Tags from All Entries
On issuing this command, either via the Tools Menu or Toolbar Button, Smart Address will remove 
the "Tag" state from any "Tagged" entries within the current Address Book.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Tagging an Entry
Showing Only Tagged Entries
Showing Only Non-tagged Entries
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Tag Command
On issuing this command via either the Tools Menu or the Keyboard Shortcut, Smart Address will 
toggle the "Tag" state of the currently selected entry.

If the entry is not "Tagged" then Smart Address will "Tag" the entry, identifying it as such by displaying
the Index Data within the Index List in Red.

If the entry is already "Tagged" then Smart Address will remove the "Tag" from the entry and also 
remove it's Red highlighting from the Index List.

Keyboard Shortcut:-
<Ctrl> and <T>

Toolbar Button:-
None.

See Also:-
Showing Only Tagged Entries
Showing Non-Tagged Entries Only
Removing All Tags from an Address Book
Hints and Tips: Tagging Entries using the Mouse.
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Show Tagged Entries
On turning on this command, either via the Tools Menu or Toolbar Button, Smart Address will only 
display entries that have been "Tagged". The Info Area of the Status Bar will also be updated, to 
reflect that the Index List is currently restricted to Tagged Entries Only. 

If an entry is un-tagged, either by use of the "Tools | Tag Entry" or the "Tools | Clear all Tags" 
command then the entry will be automatically removed from the Index List. In the case of the "Tools | 
Clear all Tags" command, an empty Index List will be displayed (i.e. there are no longer are tagged 
entries eligible to display).

This command acts as a toggle and so selecting it again will turn off the showing of Tagged entries 
and reset the Index List. 

Note: The restricting of the Index List to Tagged Entries only, can also be turned off by resetting the 
Display Index, performing an Address Search or by issuing another one of the Show Commands.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Removing All Tags from an Address Book
Tagging an Entry
Setting the Display Index
Searching an Address Book
Showing Only Non-tagged Entries
Hints and Tips: Quickly Resetting the Display Index to All Entries
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Show Non-Tagged Entries Only Command
On turning on this command via the Tools Menu, Smart Address will only display entries that have 
NOT been "Tagged" by the user. The Info Area of the Status Bar will also be updated, to reflect that 
the Index List is currently restricted to Non-Tagged Entries Only. 

If an entry's is Tagged by the user, then the entry will automatically be removed from the Index List.

This command acts as a toggle and so selecting it again will turn off the showing of Non-Tagged 
Entries Only and reset the Index List. 

Note: The restricting of the Index List to Non-Tagged Entries only, can also be turned off by resetting 
the Display Index, performing an Address Search or by issuing another one of the Show Commands.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Removing All Tags from an Address Book
Tagging an Entry
Setting the Display Index
Searching an Address Book
Showing Only Tagged Entries
Hints and Tips: Quickly Resetting the Display Index to All Entries
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Close Current Address Book
This command closes the currently active Address Book. If the Address Book has been updated but 
not yet saved, Smart Address will save the Book to disk before closing it.

If the Automatic Back-up Option is enabled, Smart Address will then create a back-up of the Address 
Book.

Keyboard Shortcut:-
None.

Toolbar Button:-

Configuring the Auto Save and Auto Back-up Facilities
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Close All Command
This command closes all active Address Books. If an Address Book has been updated but not yet 
saved, Smart Address will save the Book to disk before closing it.

If the Automatic Back-up Option is enabled, Smart Address will also create a back-up copy of each 
Address Book as it is closed.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Closing a Single Address Book
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Configure Modem Command
On issuing this command via the Options Menu, Smart Address will display the Configure Modem 
dialogue, enabling the modem and auto-dial facility of Smart Address to be configured.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Using the Auto-Dial Function
Configure Modem Dialogue
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Dial Number
On issuing this command, either via the Tools Menu or Toolbar Button, Smart Address will display the
Auto-Dial dialogue. This dialogue allows a telephone number from the currently selected entry to be 
selected for Auto-Dialing.

If the current entry does not have any eligible telephone numbers, this command will not be 
available.

The user may also use the "Fast Dial" buttons located next to the actual telephone, to dial a number. 
These buttons bypass the Auto-Dial dialogue and dial without any confirmation.

Note: A Modem must be connected to the PC and have been configured using the "Options | 
Configure Modem" command before using this facility.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Auto-Dial Dialogue
Configure Modem Command
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Select Number to Dial Dialogue
This dialogue allows the selection of a telephone to be dialed and the selection and use of a prefix to 
be added to the number being dialed. For more information, click on the required element:-

See Also:-
General Information: Using the Auto-Dial Facility
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Configure Modem Dialogue
This dialogue configures Smart Address for the Modem to be used. The dialogue is presented as two
Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the general configuration settings to be defined. For more information, click on the 
required element:-

See Also:-
Configure Modem Dialogue (Auto-Dial Options Tab)
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Configure Modem Dialogue
This dialogue configures Smart Address for the Modem to be used. The dialogue is presented as two
Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the Auto-Dial options to be defined. For more information, click on the required 
element:-

See Also:-
Configure Modem Dialogue (Configure Modem Tab)
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Copy Entry Command
On issuing this command, either via the Edit Menu or Keyboard Shortcut, Smart Address will copy 
the currently selected entry to the Windows Clipboard. This entry can then be inserted to other 
application or used to be pasted into another entry within the same or different Address Book

Keyboard Shortcut:-
<Alt> and <C>

Toolbar Button:-
None.

See Also:-
Pasting into an Entry
Hints and Tips: Copying a Field to and from the Windows Clipboard
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Paste Entry Command
On issuing this command, either via the Edit Menu or Keyboard Shortcut, Smart Address will paste 
the Address Book Entry contained within the Clipboard, into the current entry's "Data Page".

Note: For this command to be available, a entry must have first have been copied from an Address 
Book to the Clipboard and the Address Book must be in either New Entry Mode or Update Entry 
Mode.

Keyboard Shortcut:-
<Alt> and <V>

Toolbar Button:-
None.

See Also:-
Copying an Entry
Updating an Address Book Entry
Adding a New Entry to an Address Book
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Define Word Processor Command
On issuing this command via the Options Menu, Smart Address will display the Define Word 
Processor dialogue enabling the Word Processor being used, and the fields required for insertion, to 
be defined.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Inserting an Entry into a Word Processor
Define Word Processor Dialogue
Inserting Empty Fields to a Word Processor
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Insert Entry to Word Processor
On issuing this command, either via the Edit Menu or Toolbar Button, Smart Address will insert the 
current entry into a Word Processor. Smart Address will insert the required data into the Word 
processor's current document and at the cursors location.

For this command to work, the Word Processor has to be defined and the Entry fields to be inserted 
chosen by using the "Options | Define Word Processor" command. The Word Processor defined also
has to be running for the insertion to take effect.

Note:-
Smart Address will use the first instance of the Word Processor it finds for the insertion. If there are 
multiple instances of the Word Processor running, it can not be guaranteed which instance will 
receive the data.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Define Word Processor Command
Inserting Empty Fields to a Word Processor
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Define Word Processor Dialogue
This dialogue allows a user to define the Word Processor to be used and also to define which fields 
are to be inserted to the Word Processor when requested. For more information, click on the 
required element:-

See Also:-
Hints and Tips: Adding a New Word Processor to Smart Address
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Delete Selected Entry
On issuing this command, either via the Edit Menu, Toolbar Button or Keyboard Shortcut, Smart 
Address will delete the currently selected entry from the Address Book.

If the Delete Confirmation option is enabled, see "Options | Preferences", a confirmation dialogue will
be displayed before the entry is deleted. If the option is not enabled, then the entry will be deleted 
without prompting.

If more than one entry is required to be deleted, then the "Edit | Delete Entries" command may be 
used.

Keyboard Shortcut:-
<Del>

Toolbar Button:-

See Also:-
Delete Entries Command
Preferences Command
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Delete Entries Command
On issuing this command via the Edit Menu, Smart Address will display the Delete Entries dialogue, 
enabling the a range of entries to be selected for deletion from the current Address Book.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Deleting a Single Entry Quickly
Delete Entries Dialogue
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Delete Entries Dialogue
This dialogue allows a selection of entries to be deleted from the current Address Book. For more 
information, click on the required element:-
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Exit Command
This command will terminate Smart Address and close all active Address Books. If an Address Book 
has been updated but not yet saved, Smart Address will save the Book to disk before closing it.

If the Automatic Back-up Option is enabled, Smart Address will also create a back-up copy of each 
Address Book as it is closed.

When Smart Address is closed, it remembers its current state and when it's next restarted, it will 
restore everything (screen position, books open, index criteria's, etc.) to this state.

Keyboard Shortcut:-
<Alt> and <F4>

Toolbar Button:-
None.
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Export Command
On issuing this command    via the File Menu, Smart Address will display the Export Dialogue 
allowing a selected range of entries to be exported to a text file.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Export Dialogue
Import Command
Technical Specifications of the Export File Format
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Export Address Book Dialogue
This dialogue allows a selection of entries to be exported to a text file. For more information, click on 
the required element:-

See Also:-
Export File Layout Dialogue
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Export Dialogue
This dialogue allows the layout of the text file being created, to be specified and mapped to the 
various data fields within the Address Book. The dialogue is presented as four Tab Pages which may 
be paged by clicking on the Tab Area.

For more information, click on the required element:-

See Also:-
Technical Specifications of the Export File Format
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Import Command
On issuing this command    via the File Menu, Smart Address will display the Import Dialogue 
allowing a text file of entries to be imported to the current Address Book.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Import Dialogue
Export Command
General Information: Importing Text Files to Smart Address
Technical Specifications of the Import File Format
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Change Font Command
On issuing this command via the Options Menu, Smart Address will display the Change Font 
dialogue. From this dialogue a font may be selected for use as the permanent Address Book font and
will be applied to all Address Books.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.
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About Smart Address Command
On issuing this command via the Help Menu, Smart Address will display the Smart Address About 
dialogue. This dialogue provides information on the current build and version of Smart Address that 
is being run.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.
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Help Contents Command
On issuing this command via the Help Menu or Keyboard Shortcut, Smart Address will display the 
Contents screen of this Help File.

Keyboard Shortcut:-
<F1>

Toolbar Button:-
None.

See Also:-
Search for Help On Command
Using Help Command



Search for Help On Command
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Search for Help On Command
On issuing this command via the Help Menu or Keyboard Shortcut, Smart Address will display the 
Search Dialogue for this Help File, allowing the user to search for any required keyword.

Keyboard Shortcut:-
<Ctrl> and <F1>

Toolbar Button:-
None.

See Also:-
Help Contents Command
Using Help Command



Using Help Command
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Using Help Command
On issuing this command via the Help Menu, Smart Address will display the Windows Guide to Using
Help Files. This guide provides basic information on how to use Windows Help files.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Help Contents Command
Search for Help On Command



Order Smart Address Command
Copyright © 1995 Oakley Data Services
Call +44 (0)1270 759739, Fax +44 (0)1270 765272, CIS 74774,1347

Order Smart Address Command
On issuing this command via the Help Menu, Smart Address will display the Order Form for ordering 
copies of Smart Address.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Smart Address is Shareware - What's that ?



Address Book Information Command
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Address Book Information Command
On issuing this command via the File Menu, Smart Address will display the Address Book Information
dialogue, which provides various statistics on the current Address Book

Keyboard Shortcut:-
<Ctrl> and <I>

Toolbar Button:-
None.

See Also:-
Address Book Information Dialogue



Address Book Information Dialogue
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Address Book Information Dialogue
This dialogue provides information on the currently selected Address Book. For more information, 
click on the required element:-



Most Recently Used Files List
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Most Recently Used Files List
Within the File Menu, a list of the last five Address Books closed is maintained. This allows quick 
access to these books by simply selecting the Address Book required from the list.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Opening an Existing Address Book



Open Existing Address Book
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Open Existing Address Book
This command allows an Address Book to be opened.

On issuing this command, either via the File Menu or the Toolbar Button, a dialogue box will be 
displayed allowing the Address Book required to be specified. Smart Address will, by default, limit the
files displayed within this dialogue box to those with the Smart Address File Prefix of .ADR. 

Once an Address Book has been specified, Smart Address checks that the file isn't already opened, 
if it is Smart Address will give an audible beep, display the Address Book and cancel the Open 
request.

If the Address Book being opened has been marked as Read Only by Windows File Manager, or the 
user opening the Address Book does not have the required Network File Permissions to update it, 
the Address Book will be opened as Read Only and all update functions for that Address Book will be
disabled.

Once successfully opened, Smart Address will display the Address Book.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Most Recently Used Files List
Hints and Tips: Automatic Recovery of Corrupt Address Books
Hints and Tips: Creating Address Book Icons on your Desktop
Hints and Tips: Networking Address Books
Hints and Tips: Converting Old Version Address Books



Create New Address Book
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Create New Address Book
This command allows a new Address Book to be created.

On issuing this command, either via the File Menu or the Toolbar Button, a dialogue box will be 
displayed allowing a file name for the new Address Book to be specified.

Smart Address will, by default, prefix the name entered with the Smart Address File Prefix of .ADR. It 
is recommended that this default is always used, either by only entering a one to eight character 
name without any prefix (e.g. MYBOOK) or adding an .ADR prefix after the name (e.g. 
MYBOOK.ADR).

Once a name has been entered Smart Address checks that the file isn't already opened, if it is Smart 
Address will give an audible beep, display the Address Book and cancel the New request.

Once successfully created, Smart Address will display the Address Book.

Keyboard Shortcut:-
None.

Toolbar Button:-



Print Selected Entry to Envelope
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Print Selected Entry to Envelope
On issuing this command, either via the File Menu or Toolbar Button, Smart Address will print the 
selected entry using the currently defined Envelope Printer and Style

This is a 'quick print' command, therefore no print confirmation dialogues will be displayed.

If more than one entry is required to be printed, then the "File | Print Envelope(s)" Command, may be
used.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Print Envelope(s) Command
Printer Setup Command



Print Envelopes Command
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Print Envelopes Command
On issuing this command, either via the File Menu or Keyboard Shortcut, Smart Address will display 
a dialogue allowing a selection of entries to be printed to Envelopes.

Keyboard Shortcut:-
<Ctrl> and <P>

Toolbar Button:-
None.

See Also:-
Print Envelopes Dialogue
Printer Setup Command
Printing Label(s) or Listing(s) Command



Print Envelopes Dialogue
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Print Envelopes Dialogue
This dialogue allows a selection of entries to be printed to envelopes. For more information, click on 
the required element:-



Printer Setup Command
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Printer Setup Command
On issuing this command via the File Menu, Smart Address will display the Printer Setup Dialogue. 
This dialogue allows Smart Address to set-up the printers, printer styles and printer options that the 
user requires.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Printer Setup Dialogue
Printing Envelopes Command
Printing Labels or Listings Command



Printer Setup Dialogue
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Printer Setup Dialogue
This dialogue allows the Print Styles for both Envelopes and Labels / Listings to be set-up. The 
dialogue is presented as three Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the values that relate to both Styles to be defined. For more information, click on 
the required element:-

See Also:-
Printer Setup Dialogue (Envelope Tab)
Printer Setup Dialogue (Labels / Listings Tab)



Printer Setup Dialogue
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Printer Setup Dialogue (Envelope Tab)
This dialogue allows the Print Styles for both Envelopes and Labels / Listings to be set-up. The 
dialogue is presented as three Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the Envelope Style to be defined. For more information, click on the required 
element:-

See Also:-
Printer Setup Dialogue (Options Tab)
Printer Setup Dialogue (Labels / Listings Tab)



Printer Setup Dialogue
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Printer Setup Dialogue (Labels / Listings Tab)
This dialogue allows the Print Styles for both Envelopes and Labels / Listings to be set-up. The 
dialogue is presented as three Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the Label / Listings Style to be defined. For more information, click on the required 
element:-

See Also:-
Printer Setup Dialogue (Options Tab)
Printer Setup Dialogue (Envelope Tab)



Print Labels or Listings Command
Copyright © 1995 Oakley Data Services
Call +44 (0)1270 759739, Fax +44 (0)1270 765272, CIS 74774,1347

Print Labels or Listings Command
On issuing this command via the File Menu, Smart Address will display the Print Labels or Listings 
dialogue allowing a selection of entries to be printed to either labels or listings.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Print Labels or Listings Dialogue
Printer Setup Command
Printing Envelopes Command



Print Labels or Listings Dialogue
Copyright © 1995 Oakley Data Services
Call +44 (0)1270 759739, Fax +44 (0)1270 765272, CIS 74774,1347

Print Labels or Listings Dialogue
This dialogue allows a selection of entries to be printed to labels or listings. For more information, 
click on the required element:-



Print Selected Entry to Labels or Listings
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Print Selected Entry to Labels or Listings
On issuing this command, either via the File Menu or the Toolbar Button, Smart Address will print the 
selected entry using the currently defined Label/Listing Printer and Style.

This is a 'quick print' command, therefore no print confirmation dialogues will be displayed. The 
exception to this is if the Style set-up is for a label, in this case a dialogue box will be displayed 
allowing a number of labels to be skipped before printing commences. This enables, part printed 
sheets of labels to be re-used.

If more than one entry is required to be printed, then the "File | Print Labels(s) or Listing(s)" 
Command may be used.

Keyboard Shortcut:-
None.

Toolbar Button:-

See Also:-
Print Label(s) or Listing(s) Command
Printer Setup



Save Command
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Save Command
On issuing this command via the File Menu, Smart Address will save the current Address Book to 
disk.

Note: This command will only be available if the Address Book has been updated since the last save.
By default, Smart Address saves an Address Book after every update, using the Auto-Save facility, 
but this facility may be configured or turned off by the user.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Configuring the Auto-Save Facility
Save As Command



Save As Command
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Save As Command
On issuing this command via the File Menu, Smart Address will display a dialogue allowing a file 
name to be specified. 

This file name will then be used to create a copy of the current Address Book and then make that 
new Address Book active, closing down the original copy before doing so.

Note: Any updates made before the Save As command is issued will be saved to the original book 
prior to the copy being taken. In effect, the Save As command, makes a copy of an Address Book as 
the original Book will remain on disk after the Save As command completes.

Keyboard Shortcut:-
None.

Toolbar Button:-
None.

See Also:-
Save Command



Undo Last Update
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Undo Last Update
On issuing this command, either via the Edit Menu, Toolbar Button or the Keyboard Shortcut, Smart 
Address will undo the last update performed against the current Address Book.

For example if you have just deleted an entry in error, then the entry can be restored by using this 
command.

Caution: To restore an update, you must perform the Undo before you make anymore updates as the
Undo Command only holds the last update made.

Keyboard Shortcut:-
<Alt> and <Backspace>

Toolbar Button:-



User Access Allowed
This panel enables the level of access to the Address Book to be defined.



Delete
Checking this field, enables the Delete function to any user of the Address Book.

Unchecking the field, prevents users deleting entries from the Address Book.



Export
Checking this field, enables the Export function to any user of the Address Book.

Unchecking the field, prevents users performing Address Book exports.



Print
Checking this field, enables all the Print functions to any user of the Address Book.

Unchecking the field, prevents users producing any prints from the Address Book.



Update
Checking this field, enables all the Update functions to any user of the Address Book.

Unchecking the field, prevents users performing any entry update.



Address Book
This panel details the Address Book file the access privileges will be effective for.



OK Button
The OK Button applies the specified access privileges to the current Address Book, before 
terminating this dialogue.



Action
This panel informs the user what action will be taken against the reminder when it is Acknowledged.

Either the reminders date will be advanced by the period indicated by the reminder, or, if the 
reminder was a once only reminder, then the date will not be changed, but the reminder will be 
changed to "No Reminder".



Acknowledgment
This panel informs the user which reminder is being Acknowledged, the reminders current date and 
the date that will be set for that reminder when the acknowledgment is confirmed.



OK Button
The OK Button will acknowledge the set reminder and advance the date by the period indicated by 
the reminder, before terminating the dialogue.

If the reminder was a once only reminder, then the date will not be changed, but the reminder will be 
changed to "No Reminder".



Cancel Button
The Cancel Button will cancel any changes made within the dialogue and terminated the requested 
function.



Auto Identify Extension Numbers
This panel allows the user to specify an extension number length which Smart Address uses to 
automatically identify an internal telephone extension.

When Smart Address identifies a telephone number as being that of an internal extension, it will not 
append any defined prefix to the number. 

For example, Smart Address has been told to prefix all dialed telephone numbers with a "9" to select 
an outside line. It has also been told that extensions have a length of 4. When the number "01270 
759739" is dialed, Smart Address will actually dial "9 01270 759739". But when the number "2792" is 
dialed, Smart Address recognizes this as a extension (length is 4) and dials "2792" (note the 
absence of the "9" for an outside line).



Automatic Re-dial
This panel allows the Automatic Re-dial facility to be configured. 

The Automatic re-dial facility allows a dialed telephone to be re-dialed if that number is found to be 
busy.



Delay between Re-dials (Seconds)
This field allows a delay to be specified for Smart Address to wait before retrying a busy telephone 
number.



Enable Automatic Re-dial
Checking this field instructs Smart Address to retry a dialed number if it finds that number to be busy.
Smart Address will continue to dial the number until either it becomes free or is canceled by the user.



Dial Tone
This panel allows the type of dial tone used by the telephone system to be specified. Select the 
"Tone" setting if on a exchange that uses tone dialing, otherwise select the "Pulse" setting for 
exchanges that use pulse dialing.



Initialization
This field allows a Modem Initialization string to be defined. This string is sent to the modem prior to 
any automatic dialing by Smart Address

Note: If the AT command prefix for modem commands is not specified, then Smart Address will 
automatically add the AT prefix for you.



OK Button
The OK Button will configure Smart Address for your modem, before terminating this dialogue.



Port
This field should specify the communications port that is being used by your Modem. The port 
required should be selected from the 'drop-down' list.



Baud
This field should specify the baud rate (or speed) that you wish to use for your Modem. The baud 
rate required should be selected from the 'drop-down' list.



Modem Time-out Value (Seconds)
This field allows a modem time-out value to be defined. This value is used to terminate any modem 
function if a response is not received from the modem in this period of time.



Address Book will be Backed Up to
This panel details the back-up file that will be created when converting the Address Book being 
opened.

Note: If the "Do Not Create a Back-up Copy" field is checked, then no back-up will be taken.



Do Not Create a Back-up Copy
Selecting this field instructs Smart Address not to create a back-up copy of the Address Book prior to 
performing the conversion.

Warning: It is NOT recommended to convert any Address Book, without first having a back-up copy 
taken. This field should only be selected if you are sure that you already have a back-up copy of the 
Address Book. If in doubt, do not select this field.



Address Book
This panel details the Address Book that is being opened.



Cancel Button
The Cancel Button terminates the Address Book open command and therefore doesn't convert or 
open the specified Address Book.



Convert Button
The Convert Button should be used to instruct Smart Address to convert the Address Book to a 
Version 2.x format file before opening the book.



Read-Only Button
The Read-Only Button instructs Smart Address not to convert the Address Book being opened, but to
open it with Read Only access.

Note: The Address Book cannot be updated until it is converted to the new file format.



Dialog Caption Bar
The Caption Bar (window title) indicates what conversion is about to take place and details the 
version of Smart Address that created the file being opened.



Select Fields for Insertion
This panel allows the fields that will be inserted to the Word Processor document, to be chosen by 
simply checking the appropriate field.

Additional fields may be accessed by using the Page Tabs.

Note: This field definition is unique between Address Books



OK Button
The OK Button will apply the Word Processor definition to Smart Address, before terminating.



Select Word Processor
This panel allows the Word Processor being used by the user, to be chosen from the 'drop-down' list.

In order to use the "Edit | Insert in Word Processor" command, the Word Processor application being
used must be defined, otherwise the insertion will not work.



Complete Index List
Selecting this field will cause all entries in the Index List to be deleted.



OK Button
The OK Button will allow the Delete Entries Request to continue for the entries selected.



Delete Required
This panel allows the range of entries to be deleted, to be chosen.



Selected Entry
By selecting this field, only the currently selected entry will be deleted.



All Tagged Entries
Selecting this field will cause all entries that have been tagged and appear in the Index List to be 
deleted.

Note: If there are currently no tagged entries within the Address Book, this field will be disabled.



Dial Button
The Dial Button instructs Smart Address to dial the selected number, before terminating this 
dialogue.



Number Selection
This panel allows the required telephone number to be selected for dialing. Only fields that contain a 
telephone number will be enabled for selection.



Dialing Prefix
This panel allows a prefix to be specified that can be appended to the front of any telephone number 
dialed. For example, it might be required to select an outside line by first dialing the number '9' or to 
select another telephone service provider by appending a set code before the number dialed.

Note: The Dialing Prefix will only be appended to a number if the Use Prefix field is checked.



Complete Index List
Selecting this field will cause all entries in the Index List to be printed.



Copies
By it's nature, envelope printing doesn't allow for a number of copies to be specified. Therefore the 
number of copies is set at "1".

The Copies Panel, is only enabled when printing Labels or Listings (see the "File | Print Label(s) or 
Listing(s)" command).



Selected Entry to the End of List
Selecting this field will cause all the entries, from the currently selected entry to the last entry in the 
Index List, to be printed.



OK Button
The OK Button will accept the values entered within this dialogue and produce the required print.



Printer
This field indicates the printer currently selected for printing. To change to another printer, use the 
"File | Printer Setup" command or the Setup Button on this dialogue.



Print Range
This panel allows the range of entries to be printed, to be chosen.



Selected Entry
By selecting this field, only the currently selected entry will be printed.



Sort Printout By
This Panel allows the user to specify the order that the print is to be produced in. Smart Address will 
sort the print according to the field chosen from the drop-down selection box. For example, if the user
requires the resulting print to be printed in "Category" order, then the "Category" field should be 
chosen.

By checking the "Sort by Last Word" box, Smart Address will sort the printout according to the last 
word of the specified field. By default Smart Address uses the first word of each entry in determining 
the sort order.



Style
This field indicates the selected Style to be used. To change this Style, use the "File | Printer Setup" 
command or the Setup Button on the Dialogue.



All Tagged Entries
Selecting this field will cause all entries that have been tagged and appear in the Index List to be 
printed.

Note: If there are currently no tagged entries within the Address Book, this field will be disabled.



All Button
The All Button will automatically map all available data fields to the Export File Format list.



Complete Index List
Selecting this field will cause all entries in the Index List to be exported to a text file.



Selected Entry to the End of List
Selecting this field will cause all the entries, from the currently selected entry to the last entry in the 
Index List, to be exported to a text file.



OK Button
The OK Button will allow the Export Request to continue for the range selected.



Export Range
This panel allows the range of entries to be exported, to be chosen.



Selected Entry
By selecting this field, only the currently selected entry will be exported



All Tagged Entries
Selecting this field will cause all entries that have been tagged and appear in the Index List to be 
exported.

Note: If there are currently no tagged entries within the Address Book, this field will be disabled.



Export Button
The Export Button instructs Smart Address to export the specified data fields to a text file using the 
mappings defined by this dialogue. Once Smart Address has exported the data, this dialogue will 
terminate.



Select Fields for Export
This panel presents the available data fields that can be exported from Smart Address. The panel 
consists of four tab pages and additional fields may be displayed by "tabbing" to the required page.

To create the order that Smart Address writes the data fields to the export file, select the required 
field from the Export File Format list and then click the required data field button. This will then 
associate that data field with the export field when the export is performed. To remove a export field 
from the Export File Format list, simply select the export field and click the data field button again.



Export File Format
This panel lists the available export fields. Each field is identified by a Field Number and shows if a 
data field has been mapped to that export field or not.

In order to map a field, the revenant field should be selected from the list and the required data field 
button used to associate the two fields.



Reset Button
The Reset Button will remove any set mappings for the export file and return all Export File Format 
fields to <Not Mapped>



Save Field Names as Default
Checking this field will instruct Smart Address that when the OK Button is pressed, the field labels 
within this dialogue will become the default field labels. This will mean that all new Address Books 
created, will be created with these field labels already set.



Default Button
The Default Button will restore all the field labels to their defaults.



Field Labels
This panel allows the Labels for each field to be set, by simply typing the required label in the 
appropriate field.

Additional fields may be accessed by using the Page Tabs.

Note: These field labels are unique between Address Books



OK Button
The OK Button will set the fields labels within the current Address Book to the values set by this 
dialogue, before terminating.



Help Button
This button displays the Help File for the Dialogue.



All Button
The All Button with automatically map the text file to the Smart Address Data Fields.

Note: This Button will only map correctly, if the text file was created using the All button of the Smart 
Address Export command.



Import Fields
This panel lists the available fields for import to Smart Address. Each field is identified by a Field 
Number and shows an extract from the import file to help identify what fields are what.

In order to map a field, the revenant field should be selected from the list and the required mapping 
button used to associate the two fields.



Import Button
The Import Button instructs Smart Address to import the specified text file using the mappings 
defined by this dialogue. Once the text file has been imported Smart Address will terminate this 
dialogue.



Data Mapping Buttons
This panel presents the available data fields that the import files contents can be mapped to. The 
panel consists of four tab pages and additional fields may be displayed by "tabbing" to the required 
tab page.

To map an import field, select the required field from the Import Fields list and then click the required 
mapping button. This will then associate that import field with that data field when the import is 
performed. To remove a mapped field, simply click the mapping button again and this will return the 
import field back to the Import Fields list.

Import fields may be merged together by using both the mapping buttons associated with a data 
field. For example, if the import file has the name as two separate entries, one as first name and one 
as surname, these can be merged into one entry of "first_name surname".



Use First Line of Import File to Set Field Labels
When this field is checked, Smart Address will set the field labels for the Address Book receiving the 
import, to the values specified in the first line of the import file.

If this field is not checked then Smart Address will import the first line as an entry.



Index Category
This panel allows the Index Category for the Index Criteria to be chosen.

By default the Index Category will be <All Categories> resulting in all entries being eligible for 
display. The user may define a different category for restricting the entries displayed, by either 
entering a category or choosing one from the 'drop-down' list.

If the "Wild Match" field is selected then this means that any category beginning with the category 
chosen will be eligible for display. For example, a category of 'CONTACTS' and the Wild Match field 
selected, would make the entries with the following categories eligible for display :-

Contacts
Contacts - Personal
Contacts - Business
Contacts - Press

De-selecting the Wild Match field, would result in only the following category being eligible for 
display:-

Contacts



Index Character
This panel allows the Index Character to be used by the Index Criteria to be specified. In order to 
chose a character, simply click on the character button required. To set the Index Character to all 
characters, the All Button should be used.

The Index Character is used to restrict the entries displayed within the Index List to certain entries 
only. For more information, see the Indexed On field on this dialogue.



Indexed On
This panel allows the Indexed On settings of the Index Criteria to be set. The Indexed On setting, 
determines how Smart Address uses the Index Character for restricting the entries displayed. 
Depending on this setting, Smart Address will either match the Index Character against the first letter
of the first word, the first letter of the last word or the first letter of every word of the entry's index 
record. Only entries that provide a match for the Index Character and the Index Category will be 
displayed.

There are three values for the Indexed On setting - First Word, Last Word, All Words

This setting is also used to determine the order that entries are displayed within the Index List. If the 
setting is "Last Word", then the Index List will be sorted on the last word of each entry's Index Field. 
Otherwise, the Index List will be sorted on the first word of each entry's Index Field.



OK Button
The OK Button will set the Index Criteria for the current Address Book, based on the settings defined 
by this dialogue. The Index List will be rebuilt to display only entries matching this criteria before the 
dialogue is terminated.



Reset Button
The Reset Button will reset the Index Criteria to display all entries within the Address Book. The 
Index List will be rebuilt to display all entries before the dialogue is terminated.



Access Allowed
This field details the degree of access the user has to the Address Book. This may be either:-

UPDATE - Full Access is allowed
READ ONLY - Only the Read Functions are available

Additional access restrictions may also be in effect. See the Access Allowed field in the Supplier 
Panel.



Address Book Created
This field indicates the date and time that the Address Book was created. If the Address Book was 
converted from a pre-version 2.x Address Book, then this date will not be available and will therefore 
be displayed as "Not Available"



File Name
This field provides the fully qualified file that is the Address Book. This File Name is the name that 
Smart Address uses to store the Address Book on disk.



Address Book
This field contains the Name of the Address Book. This is the Name that is displayed within the 
Address Book's Window Title.



No.
This field indicates the total number of entries contained within the Address Book.



OK Button
This button terminates the displayed dialogue.



Supplier Panel
This panel relates to commercially supplied Address Books. If the Address Book currently open is not
a commercial book, then this panel will be disabled.

Address Book Supplied By
If the Address Book has been purchased from another company, then this field will detail the name of
the company that supplied the Address Book.

Access Allowed
Companies that retail Address Lists using Smart Address, can set the level of access that is allowed 
against any Address Book supplied by them. This access will be indicated by the associated boxes 
being checked for the level of access that is available.



Last Updated
This field indicates the date and time that the Address Book was last updated.



Copies
This Panel allows the user to specify the number of copies of each entry required.

If a Listing Print Style is selected, then the number of copies relate to each page of the listing, with 
multiple entries on each page.

If a Label Print Style is selected, then the number relates to each entry. For example, if you 
requested 3 copies, then 3 copies of the first entry would be printed followed by three copies of the 
next entry and so on.



Full Sheet of Labels for Each Entry
Select this field to instruct Smart Address to print a complete sheet of labels for each entry printed. 
For example, if the Label Style defined is for labels that are 8 deep by 2 wide, then Smart Address 
will print 16 copies of each entry.

Note: This field is only available when a Label Print Style is defined.



Number of Copies
Select this field to control the numbers of copies by a set number. Once selected, then the Number of
Copies text field will become available. This field should be completed with the number of copies 
required.
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Envelope Layout Dialogue
This dialogue allows the physical layout of the Envelope Style to be set-up. The dialogue is 
presented as four Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the general envelope settings to be defined. For more information, click on the 
required element:-

See Also:-
Envelope Layout Dialogue (Mail Address Tab)
Envelope Layout Dialogue (Return Address Tab)
Envelope Layout Dialogue (Logo Tab)
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Envelope Layout Dialogue
This dialogue allows the physical layout of the Envelope Style to be set-up. The dialogue is 
presented as four Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the print location of the Mail Address to be specified. For more information, click on 
the required element:-

See Also:-
Envelope Layout Dialogue (Options Tab)
Envelope Layout Dialogue (Return Address Tab)
Envelope Layout Dialogue (Logo Tab)
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Envelope Layout Dialogue
This dialogue allows the physical layout of the Envelope Style to be set-up. The dialogue is 
presented as four Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the print location of the Return Address to be specified. For more information, click 
on the required element:-

See Also:-
Envelope Layout Dialogue (Options Tab)
Envelope Layout Dialogue (Mail Address Tab)
Envelope Layout Dialogue (Logo Tab)
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Envelope Layout Dialogue
This dialogue allows the physical layout of the Envelope Style to be set-up. The dialogue is 
presented as four Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the print location of the Logo to be specified. For more information, click on the 
required element:-

See Also:-
Envelope Layout Dialogue (Options Tab)
Envelope Layout Dialogue (Mail Address Tab)
Envelope Layout Dialogue (Return Address Tab)



Envelope Picture - Options Tab
This picture represents the orientation chosen for the Envelope. 

Note: This is not a scaled picture, i.e. it doesn't represent the true size/shape of the envelope, but is 
used to provide a visual reference to the orientation chosen.



Picture - Logo Tab
This picture represents the location of the Logo and indicates where the location measurements are 
taken from. 

Note: This is not a scaled picture, i.e. it doesn't represent the true physical location of the Logo, but is
used to provide a visual reference to where the location measurements are taken from.



Picture - Mail Address Tab
This picture represents the location of the Mail Address and indicates where the location 
measurements are taken from. 

Note: This is not a scaled picture, i.e. it doesn't represent the true physical location of the Mail 
Address, but is used to provide a visual reference to where the location measurements are taken 
from.



Picture - Return Address Tab
This picture represents the location of the Return Address and indicates where the location 
measurements are taken from. 

Note: This is not a scaled picture, i.e. it doesn't represent the true physical location of the Return 
Address, but is used to provide a visual reference to where the location measurements are taken 
from.



Font Button
The Font Button allows the font for the current object (Mail Address or Return Address) to be 
specified.

The font chosen is associated with the current Print Style, i.e. different Print Styles can have different
fonts defined for these objects.



Height
This field allows the Height of the Envelope being used to be specified.

Note: If this field is disabled, then the Envelope Style currently selected is one of the supplied 
envelope definitions, therefore changes to it's Height is not allowed



Offset from left
This field allows the horizontal print position for the current object (Mail Address, Return Address or 
Logo) to be specified.

Note: This print position is specified from left edge of the stationary being used..



Measurement Unit
This field indicates the current unit used for measurement.

This measurement unit may be changed by via the International Option of the Windows Control 
Panel.



OK Button
The OK Button defines the Print Style chosen using the values entered on this dialogue, saves them 
to the Smart Address Configuration file and then terminates the dialogue.



Envelope Orientation
This Panel allows the orientation of the Envelope to be chosen. The envelope picture provides a 
visual reference of the orientation chosen, with the picture of the envelope changing between portrait
and landscape accordingly.



Print Position for Logo Position
This panel allows the print positions, for location of the Logo on the output, to be specified.



Print Position for Mailing Address
This panel allows the print positions, for location of the Mailing Address on the output, to be 
specified.



Print Position for Return Address
This panel allows the print positions, for location of the Return Address on the output, to be specified.



Envelope Size
This panel allows the Envelope Size to be defined. Without the correct dimensions, Smart Address 
will not be able to correctly position the output on any Envelopes printed.

Note: If these fields are disabled, then the Envelope Style currently selected is one of the supplied 
envelope definitions, therefore changes to these values are not allowed.



Print Style
This field indicates the Print Style current in effect.



Offset from Top
This field allows the vertical print position for the current object (Mail Address, Return Address or 
Logo) to be specified.

Note: This print position is specified from top edge of the stationary being used..



Width
This field allows the Width of the Envelope being used to be specified.

Note: If this field is disabled, then the Envelope Style currently selected is one of the supplied 
envelope definitions, therefore changes to it's Width is not allowed.
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Label Layout Dialogue
This dialogue allows the physical layout of the Label Style to be set-up. The dialogue is presented as
four Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the general label settings to be defined. For more information, click on the required 
element:-

See Also:-
Label Layout Dialogue (Mail Address Tab)
Label Layout Dialogue (Return Address Tab)
Label Layout Dialogue (Logo Tab)
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Label Layout Dialogue
This dialogue allows the physical layout of the Label Style to be set-up. The dialogue is presented as
four Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the print location of the Mail Address to be specified. For more information, click on 
the required element:-

See Also:-
Label Layout Dialogue (Options Tab)
Label Layout Dialogue (Return Address Tab)
Label Layout Dialogue (Logo Tab)
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Label Layout Dialogue
This dialogue allows the physical layout of the Label Style to be set-up. The dialogue is presented as
four Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the print location of the Return Address to be specified. For more information, click 
on the required element:-

See Also:-
Label Layout Dialogue (Options Tab)
Label Layout Dialogue (Mail Address Tab)
Label Layout Dialogue (Logo Tab)
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Label Layout Dialogue
This dialogue allows the physical layout of the Label Style to be set-up. The dialogue is presented as
four Tab Pages which may be paged by clicking on the Tab Area.

This Tab enables the print location of the Logo to be specified. For more information, click on the 
required element:-

See Also:-
Label Layout Dialogue (Options Tab)
Label Layout Dialogue (Mail Address Tab)
Label Layout Dialogue (Return Address Tab)



No. Across
This field is used to specify the number of labels across per sheet.

Note: If this field is disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to this value is not allowed.



Label Definition
The panel allows the size definition for the selected label to be defined. Without the correct 
dimensions, Smart Address will not be able to correctly position the output on any Labels printed.

Note: If these fields are disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to these values are not allowed.



No. Down
This field is used to specify the number of labels down per sheet.

Note: If this field is disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to this value is not allowed.



Label Height
This field is used to specify the physical height of a single label.

Note: If this field is disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to this value is not allowed.



Horz. Gap
This field is used to specify the horizontal gap between labels on the sheet. This is the measurement 
of the gap between labels 'across' the sheet.

Note: If this field is disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to this value is not allowed.



Left Margin
This field is used to specify the left margin of the label sheet. This is the measurement of the gap 
between the left edge of the page and the left edge of the first label.

Note: If this field is disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to this value is not allowed.



Top Margin
This field is used to specify the top margin of the label sheet. This is the measurement of the gap 
between the top of the page and the top of the first label.

Note: If this field is disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to this value is not allowed.



Vertical Gap
This field is used to specify the vertical gap between labels on the sheet. This is the measurement of 
the gap between labels 'down' the sheet.

Note: If this field is disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to this value is not allowed.



Label Width
This field is used to specify the physical width of a single label.

Note: If this field is disabled, then the Label Style currently selected is one of the supplied label 
definitions, therefore changes to this value is not allowed.



Default Category
This panel allows a default category to be defined which will be used as the initial category for all 
new entries and for any imported entry that does not have a category.

Note: This setting is unique to each Address Book



Save as Default for New Address Books
Checking this field will instruct Smart Address that when the OK Button is pressed, the settings 
defined within this tab page will become default. This will mean that all new Address Books created, 
will be created with these settings already defined.



Default Index Field
This panel allows the Default Index Field for an Address Book to be defined. By default, new entries 
are created with the Index Field set to <Default Index>. Smart Address will then use the field that is 
defined as the Default Index Field, to extract the Index data that is to be used. 

Changing this value, will cause all entries that are set to <Default Index> to be re-indexed 
automatically to the new Default Index Field.

Note: This setting is unique to each Address Book



Reminder Options
This panel allows the Smart Address settings related to the date reminders facility, to be configured 
to the users requirements.

Note: These settings are unique to each address book.



Indicate Active on Index List
Selecting this field instructs Smart Address to place an "Active Reminder" marker to the left of the 
Index entry within the Index List. This allows a visual representation to be given, showing entries in 
the Index List that have "Active Reminders" present.

Note: This setting is unique to each Address Book



Advance Warning at x Days
This field allows the number of days for an advance warning of a date reminder to be set.

Smart Address indicates dates that will be becoming due, by turning on a yellow notification marker 
for the entry. The Advance Warning field, controls how far ahead Smart Address checks for due 
dates.

Note: This setting is unique to each Address Book



General
This panel allows the general Smart Address settings to be configured to the users requirements.



Keep Active Tab between Entries
Checking this field, instructs Smart Address not to change Tabs (Data Pages) between different 
entries. 

For example, if the user is currently viewing the Reminders Tab and then selects another entry for 
display, if this field is not checked the current Tab will be changed to the Address Tab. With this field 
checked, the Reminders Tab would remain displayed.



Enable Fast Edit of Entries
Checking this field will enable the Fast Edit facility of Smart Address. This facility enables the Update 
Entry Mode when a data field is clicked with the mouse or is tabbed into using the TAB Key.

Without this facility enabled, the Toolbar or Menu Command must be used to update an entry.

Note: The Fast Edit facility will automatically enable the New Entry Mode if the Index List is empty 
when a data field is clicked or tabbed into.



Use Vertical Tabs
Checking this field instructs Smart Address to use vertical tab markers instead of horizontal markers.



Enable Toolbar Tooltips
Selecting this field enables the displaying of "tooltips" when the mouse pauses over a toolbar button. 
A "tooltip" is a short description, displayed just below the toolbar button, describing the function of the
button.



Import / Export Options
This panel allows the Smart Address settings related to importing and exporting
Address Books, to be configured to the users requirements.



Export Address as Single Record
Checking this field instructs Smart Address to export an entry's Address as a single record. 

By default, Smart Address will export the five Address Lines of an entry as five separate records, 
separated by the specified Separation Character. If the user requires the Address exported as a 
single record, then this field should be checked. Smart Address will then export the address as one 
record, with each Address Line being separated by a Carriage Return and Line Feed.



Field Separation Character
This field allows the specification of the character to be used to separate data fields when exporting 
or importing Address Books. For example, if this character is "," then an export would output an entry
as :-

"Title","Name","Position", .... and so on ....



OK Button
The OK Button will apply any changed settings to Smart Address, before terminating this dialogue.



Confirmations
This panel allows the Smart Address settings related to confirming user actions, to be configured to 
the users requirements.



Confirm Acknowledgments
Checking this field instructs Smart Address to request confirmation by the user, before any Date 
Reminders are acknowledged.



Confirm Category Additions
Checking this field instructs Smart Address to request confirmation by the user, before an unknown 
Category is applied to a entry.



Confirm Address Book Deletions
Checking this field instructs Smart Address to request confirmation by the user, before any entries 
are deleted from any Address Books.



Save Options
This panel allows the Smart Address settings related to saving Address Books, to be configured to 
the users requirements.



Enable Auto-Save
Checking this field, instructs Smart Address to save the current Address Book to disk after it has 
been updated. This ensures that if a problem was to occur with the PC (e.g. a power-cut, accidentally
being powered-off, etc.) any previous updates would not be lost.

If this field is not checked, then updates will only be saved when closing the Address Book or via use 
of the "File | Save" Command.



Back-up Address Books on Closing
Checking this field, instructs Smart Address to create a back-up copy of an Address Book when it is 
closed. This back-up can then be used to recreate the Address Book if the original file should be 
damaged or lost for some reason.

The file name given to a back-up copy will be the same as the Address Book, except that it will have 
an extension name of ".BAK". For example:-

C:\SMARTADR\EXAMPLE.ADR would be backed up as C:\SMARTADR\EXAMPLE.BAK



Updates before Auto-Save
This field allows the number of updates necessary before an automatic save of the Address Book is 
performed, to be specified.

By default, Smart Address will perform an automatic save after every update. By changing this field, 
automatic saves can be configured to be performed at a greater interval.

Note: This field will only be enabled, if the Enable Auto-Save field is checked.



Print Fields Dialogue
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Print Fields Dialogue
This dialogue allows a user to define which field entries are printed for a specified Print Style. This 
definition is associated with the actual Print Style, i.e. each Print Style has it own definition of which 
fields are printed. For more information, click on the required element:-



Select the Fields to be Printed
The fields that will be printed, when printing using the current Print Style, may be selected by 
checking the fields required. Additional fields may be accessed by using the Page Tabs.



OK Button
The OK Button creates the required Print Field Definition, associates it with the current Print Style 
and ends this dialogue.



Print Blank Fields
By default, Smart Address doesn't print data fields that are empty. By checking this field, Smart 
Address will print the data field regardless if it contains data or not.



Print the Field Labels on the Output
Checking this field, instructs Smart Address to print the field's label along with its data. 

For example, a field labeled "Company Name" with a value of "Oakley Data Services" would print out
as -

Company Name      Oakley Data Services



Print Style
This field indicates the selected Print Style that this Print Field definition is to be associated with.



Logo File Button
This button will only be enabled if the "Print Logo" field is checked. Selecting this button enables the 
Windows Bitmap file to be chosen. Once a file has been chosen, the file name will be placed in the 
"Logo File" field to the left of this button.



Logo File Name
This field will be enabled only when the "Print Logo" field is checked. When enabled, a file name 
should be entered to specify the Windows Bitmap file to be used.



OK Button
The OK Button will accept the values entered within this dialogue and define the required Print 
Styles.



Printer
This field indicates the currently selected printer for the current Print Style.

This printer may be changed by using the Printer Button on this dialogue.



Return Address
A Return Address may be printed on all Envelopes or Labels if required. If this option is enabled 
within the relevant Print Style, the Address entered within these fields will be used.

Note: The Return Address doesn't have to be an Address. It could, for example, be a message to 
appear on the envelopes printed.



Printer Button
The Printer Button allows the Printer to be used for the selected Print Style to be chosen, or set-up,    
from the list of printers installed to Windows.



Print Style
This 'drop-down' list box indicates the current style of stationary defined. This style may be changed 
by selecting the 'drop-down' arrow and choosing another style from the list displayed.



Print logo
Checking this field, instructs Smart Address to print a "logo" on the output. The Logo to be printed is 
a Windows Bitmap file, whose location is specified in the text field below the Print Logo field.

Note: This option is not available when defining Listing Styles.



Print Return Address
Checking this field, instructs Smart Address to print a "Return Address" on the output.

Note: This option is not available when defining Listing Styles.



Date Rule
This field allows a Date Rule to be defined for the search. A Date Rule allows entries that have date 
entries falling within the specified rule to be located. If no date searching is required, a Date Rule of 
<None> should be selected.

Note: For a search to take place, either the Text to Find field must be completed or a Date Rule 
defined.



End Date
This field allows the end date of a defined Date Rule to be specified. The format of the date 
displayed/entered is dependent on the International Setting within the Windows Control Panel.

Note: This field will only be enabled if an appropriate Date Rule has been selected.



Fields
This panel allows the scope of the search request to be specified. If All Fields is selected then the 
search will attempt to match against all the data fields within an entry. If Selected Fields is selected, 
then Smart Address will only attempt to match against the fields specified by the user.



All Fields
Selecting this field will instruct Smart Address to attempt to match the search request against all the 
data fields within an entry.



Selected
Selecting this field performs two functions. Firstly the dialogue will be extended automatically 
allowing individual fields to be selected for the scope of the search.

Secondly, it instructs Smart Address to only attempt to match the search request, against the 
individual fields selected by the user.



Method
This panel allows the Search method to be used, to be specified. This method controls how Smart 
Address attempts to match the text entered in the Text to Find entry field against the text in Address 
Book entries.



Specific
Selecting this field instructs Smart Address to perform a 'Specific' search when processing a search 
request.

When running a 'Specific' search, Smart Address will only match an entry that completely matches 
the search text. For example, if the Text to Find was entered as "Peter", the search would find :-

Peter

but not :-

Peterson
Mark Peters
Peter Smith
etc.



Wild
Selecting this field instructs Smart Address to perform a 'Wild' search when processing a search 
request.

When running a 'Wild' search, Smart Address will match any entry that contains the search text. For 
example, if the Text to Find was entered as "Peter", the search could find :-

Peter
Peterson
Mark Peters
Peter Smith
etc.



OK Button
The OK Button will perform the requested search and display any matching entries within the Index 
List. If no matching entries could be found the Index List will remain unchanged and a message 
issued.



Origin
This panel allows the Search Origin to be specified. The Search may be performed against the 
complete Address Book or on the subset currently displayed within the Index List. The subset option, 
allows selective searches to be performed by searching on search results, etc.



Book
Selecting this field instructs Smart Address to search the complete Address Book, ignoring the 
selection currently displayed within the Index List.



Index List
Selecting this field instructs Smart Address to only search the subset currently displayed within the 
Index List. This enables selective searches to be performed by searching on a previous search 
result, etc.



Start Date
This field allows the start date of a defined Date Rule to be specified. The format of the date 
displayed/entered is dependent on the International Setting within the Windows Control Panel.

Note: This field will only be enabled if an appropriate Date Rule has been selected.



Text to Find
This field allows the text to be searched for, to be specified.

Note: For a search to take place, either the Text to Find field must be completed or a Date Rule 
defined.



Save Field Selection as Default
Checking this field will instruct Smart Address that when the OK Button is pressed, the field selection 
within this dialogue will become the default field selection. This will mean that all new Address Books 
created, will be created with only these fields showing.



Default Button
The Default Button will mark the fields to be shown based on the current default.



Select Fields to be Displayed
This panel allows the fields shown to be chosen by checking the field required. Checked fields will be
displayed in the Address Book, whilst unchecked fields will not be displayed.

Additional fields may be accessed by using the Page Tabs.

Note: The fields chosen for displaying are unique between Address Books



OK Button
The OK Button will configure the fields displayed within the current Address Book to the choice 
specified by this dialogue, before terminating.



Address Tab
Clicking on this Tab, pages the dialogue so that the fields associated with the Address Page are 
displayed.



Notes Tab
Clicking on this Tab, pages the dialogue so that the fields associated with the Notes Page are 
displayed.



Others Tab
Clicking on this Tab, pages the dialogue so that the fields associated with the Others Page are 
displayed.



Reminders Tab
Clicking on this Tab, pages the dialogue so that the fields associated with the Reminders Page are 
displayed.
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The Edit Menu
For more information, click on the required Menu Item:-

See Also:-
The File Menu
The Tools Menu
The View Menu
The Options Menu
The Window Menu
The Help Menu
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The File Menu
For more information, click on the required Menu Item:-

See Also:-
The Edit Menu
The Tools Menu
The View Menu
The Options Menu
The Window Menu
The Help Menu
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The Tools Menu
For more information, click on the required Menu Item:-

See Also:-
The File Menu
The Edit Menu
The View Menu
The Options Menu
The Window Menu
The Help Menu



The View Menu
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The View Menu
For more information, click on the required Menu Item:-

See Also:-
The File Menu
The Edit Menu
The Tools Menu
The Options Menu
The Window Menu
The Help Menu



The Options Menu
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The Options Menu
For more information, click on the required Menu Item:-

See Also:-
The File Menu
The Edit Menu
The Tools Menu
The View Menu
The Window Menu
The Help Menu



The Window Menu
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The Window Menu
For more information, click on the required Menu Item:-

See Also:-
The File Menu
The Edit Menu
The Tools Menu
The View Menu
The Options Menu
The Help Menu



The Help Menu
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The Help Menu
For more information, click on the required Menu Item:-

See Also:-
The File Menu
The Edit Menu
The Tools Menu
The View Menu
The Options Menu
The Window Menu



Order Form - SmartAddress R2

Call +44 (0)1270 759739
Fax +44 (0)1270 765272
CIS: 74774,1347

You can print this order form by using the "Print Topic" option from the "File" menu.

You will receive:-

· A copy of the latest registered version of Smart Address, without the reminder screens. Whilst we
always try to ship as quickly as we can, by Air Mail if outside the UK, please allow 21 days for 
delivery.

· Shareware versions of some of our other software, including at least SmartCat Plus - the premier
Windows File Cataloger, Smart 'n Sticky - a very sophisticated labelling package designed to 
work with Smart Address, SmartSum - a sophisticated Windows emulation of a Printing 
Calculator which can actually speak the numbers as you say them, plus whatever else we have 
that will fit on the disk.

We can accept your order by mail, E-mail, Fax or Phone. You can also register single copies via the 
Compuserve SWREG service (GO SWREG), using Product ID 4521. The cost via SWREG is $39.00
(Thirty Nine US Dollars). Unless otherwise requested we ship a 3.5" disk.

We also offer considerable discounts for multi-copy licences for use across networks, across sites or across corporations. 
Please contact us for details on +44 (0)1270 759739.

Send your order to:-
Oakley Data Services,
3 Oakley Close,
Sandbach,
Cheshire CW11 9RQ,
England.

Please send me __ registered copy(s) of Smart Address V2.

Price :- £29.38 Pounds Sterling.
(In the EEC this is made up of 25.00 Pounds, plus VAT @17.5%, no charge for shipping. In the rest 
of the world this is made up of 25.00 Pounds, plus 4.38 Pounds Air-Mail Shipping + Handling).

(As of January 1995 the exchange rate was approximately 1.55 U.S. Dollars to 1.0 Pound Sterling. When we charge your 
credit card the card company will convert the cost to your local currency at the rate then prevailing and the sum will appear on 
your bill in your local currency.)

Total Price : .......................
I enclose a cheque / wish to pay by MasterCard / Visa / Amex (delete as applicable)

(Note: We can only accept cheques payable in the UK drawn in Sterling.)
Credit Card Details:-
Name as on card:-
Card Number:- 
Expiry Date:-



Please send the registered version to:-
Name:
Address:

Post/Zip Code:                                                Day Time Tel. No.

You can also contact us by:-
Phone:+44 (0)1270 759739; FAX: +44 (0)1270 765272; Compuserve: 74774,1347
Internet: 74774.1347@compuserve.com , or via the World-Wide-Web at http://198.49.174.129,
or via Section 4 of the UKSHARE forum on Compuserve.

It would also help us if you could tell us where you got Smart Addess from:-

And any suggestions you have for enhancements:-



Order Form - Smart Address R2

Call 801 295-1890 
Fax 801 299-1781

You can print this order form by using the "Print Topic" option from the "File" menu.

We can accept your order by mail, E-mail, Fax or Phone.    Unless otherwise requested we ship a 
3.5" disk.

We also offer considerable discounts for multi-copy licences for use across networks, across sites or across corporations. 
Please contact us for details on 801 295 1890.

Send your order to:-
Insight Software Solutions
P.O. Box 354,
Bountiful, UT 84011-0354

Or Call 801 295-1890 
Or Fax 801 299-1781
Or CompuServe:    71672,3464

Please send me __ registered copy(s) of Smart Address R2.
Price Per Copy:-

Price                          $39.00 
Utah Residents add Sales Tax   $ 2.39 
Shipping by Fist Class Mail    $ 3.00
       --- or ---
Priority or Int'l shipping     $ 5.00
-----                        ------
Total                        $       
-----                        ------

All Prices are in US Dollars.

I enclose a check / wish to pay by MasterCard / Visa (delete as applicable)

Credit Card Details:-
Name as on card:-

Card Number:- 

Expiry Date:-

Please send the registered version to:-
Name:



Address:

Telephone Number.

It would also help us if you could tell us where you got Smart Address from:-

And any suggestions you have for enhancements:-



Address Book Caption Bar
The Address Book Caption Bar contains the name of the Address Book belonging to that Window.

There will be instances where additional information is displayed on the Caption Bar with the Address
Book Name. For example, an Address Book called EXAMPLE, may at times appear as:-

EXAMPLE*
Address Book Needs Saving
If the Auto-Save function (see the "Options | Preferences" command) has been disabled and the 
Address Book has been updated but not saved, then an * will be appended to the Name on the 
Caption Bar. When the Address Book has been saved, this * will be removed from the Name.

EXAMPLE [Read Only]
Address Book is Read Only
If the user does not have update access to the Address Book, either due to Network Access 
Permissions or the Book concerned has been marked as Read Only using Windows File Manager, 
then [Read Only] will be appended to the Name on the Caption Bar.



Categories Displayed
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Categories Displayed
This field on the Status Bar, indicates the current setting for the Index Category.

By default the Index Category will be <All Categories> resulting in all entries being eligible for 
display. The user may define a different category for restricting the entries displayed, by setting the 
appropriate value using the Display Index.

If the category displayed on the Status Bar is prefixed with '*', then that means that the category 
restriction is applied to categories beginning with that category. For example, a category being 
displayed as ' CONTACTS * ' would make the entries with the following categories eligible for display
:-

Contacts - Personal
Contacts - Business
Contacts - Press

During a Search, this field will indicate the type of Search that is in effect against the Address Book, 
as a Search will override the Index Category and is therefore not relevant to the subset of entries 
displayed.

See Also:-
Setting the Display Index
Performing an Address Book Search



The Data Page
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The Data Page
This area of an Address Book is used to present each entry's data. It is also used for updating and 
adding data for entries.

It is presented as four pages, or 'tabs', each containing a subset of the data connected to the entry. 
Each page may be accessed by clicking the mouse on the 'tab' required or by using the View Menu.

The Pages are :-

The Address Tab
The Notes Tab
The Reminders Tab
The 'Others' Tab

See Also:-
The View Menu



Indexed On
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Indexed On
This field on the Status Bar, indicates the current setting for the Indexed On value. This value 
determines how Smart Address uses the Index Character for restricting the entries displayed.

There are three values for this setting - First Word, Last Word, All Words

This setting is also used to determine the order that entries are displayed within the Index List. If the 
setting is "Last Word", then the Index List will be sorted on the last word of each entry's Index Field. 
Otherwise, the Index List will be sorted on the first word of each entry's Index Field.

See Also:-
Setting the Display Index



The Index List
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Index List
The Index List displays a list of each entry's Index Field, that matches the current Index Criteria, in 
the order specified by the current Index Order.

The currently selected entry will be highlighted within the Index List and the details for that entry 
displayed within the Address Book's "Data Page".

To select another entry, simply use the mouse or keyboard to move the highlight to a different field.

See also:-
Navigating the Index List
Quickly Locating an Entry within the Index List



Navigating the Index List
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Navigating the Index List
In order to move through the Index List, the following keys may be used:-

· <Left Arrow> or <Up Arrow>
These keys move up the Index List one entry at a time.

· <Right Arrow> or <Down Arrow>
These keys move down the Index List one entry at a time.

· <Page Up> or <Page Down>
These keys will either move up or down the Index List one page at a time.

· <Home> or <End>
These keys will either move to the top or bottom of the Index List

The mouse also may be used by clicking any entry to select it, or in conjunction with the Index Lists 
Scroll Bar.



Quickly Locating an Entry within the Index List
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Quickly Locating an Entry within the Index List
An entry may be located quickly by simply typing in the name your required. For instance, if you wish
to locate the entry for 'Windowshare', then as you type in 'Windowshare' the Index List will 
automatically position itself as you type in.

For example, when the 'W' is entered, the Index List will select the first entry beginning with 'W', 
when the 'i' is located then the first entry beginning with 'Wi' will be located and so on.

This will continue until either no matches can be made, indicated by a beep, a pause occurs during 
typing or one of the Index List navigation keys are used.



Number of Entries Displayed
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Number of Entries Displayed
This field on the Status Bar, indicates what subset of entries are currently displayed. If all entries are 
displayed, the default state, then both numbers will match - for example 203 of 203.

If only a subset of entries have been displayed, either by use of "Tools | Set Display Index", "Tools | 
Show xx..." or an Address Book search, then the field will show the number of entries within the 
subset. For example, 100 of 203 informs us that 100 entries out of a possible 203 have been 
included in the Index List.

See Also:-
Setting the Display Index
Performing an Address Book Search



The Status Area
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The Status Area
This field of the Status Bar, is used for general information during the day-to-day running of Smart 
Address. The most common use for this area is to notify what the current search is, that is in effect 
against the Address Book.

Another use is to notify what Show command is currently applied to the Index List.

See Also:-
Performing an Address Book Search



Address Field
These are five freeform text fields for use, by default, to specify an Address for the person or 
company concerned.

Smart Address allows the use and label of this field to be customized by the user.



Drop Down Calendar Button
These buttons will invoke a drop down calendar from which a date may be selected. Once a date is 
selected, that date will be placed in the associated date field to the left of the button pressed.



Category Field
This is a 'drop-down' list box for use, by default, to specify a category that the current entry belongs 
to. A new category may be entered into this field or an existing category chosen from the 'drop-down' 
list box. 

Smart Address requires this field to be completed for any entry.

Smart Address allows the label of this field to be customized by the user.



Company Field
This is a freeform text field for use, by default, to specify a Company Name.

Smart Address requires either this field or the Name field to be completed for any entry.

Smart Address allows the use and label of this field to be customized by the user.



Date Fields
These are three Date fields that may be used to specify reminders for certain events to be set for the 
currently selected entry. Smart Address can then 'remind' you when these dates become due. For an
example, you can set-up a reminder for a persons Birthday, a reminder for to re-contact a Client, etc.

The format of the date displayed/entered is dependent on the International Setting within the 
Windows Control Panel.

It should be noted that past dates may be used in order that fields can serve as a reminder of an 
event that has happened, as opposed to an event this is to happen. For example, a Date field may 
be used to hold the date that a Customer first became a customer.



Date Field Labels
Each of the three Date fields have a customizable label defined to them. This label should be used to
describe the type of Reminder being set. For example, Birthday, Call Customer On, First Contacted, 
etc.

It should be noted that past dates may be used in order that fields can serve as a reminder of an 
event that has happened, as opposed to an event this is to happen. For example, a Date field may 
be used to hold the date that a Customer first became a customer.



Telephone Dial Buttons
These buttons allow Smart Address to dial the associated telephone number, using Smart Address's 
Auto-Dial facility. If no associated telephone number is present, then the button will be disabled.

Smart Address allows the showing of these buttons to be turned off by the user.



Indexed On Field
This is used to define the field that is to be the Index for the currently selected entry. By default, the 
Index field will be <Default Index>, meaning that the entry will be indexed on the field the user has 
chosen as the default Index for this Address Book. This is set via "Options | Preferences".

If you wish to force an entry to always index on a certain field, regardless of what field is set as the 
default index, then choose the field from the 'drop-down' list box.

The field an entry is 'Indexed On', is the field that is displayed for that entry in the Index List.

Smart Address allows the label of this field to be customized by the user.



Reminders Legend
This field provides a legend to the various Notification Markers that may be displayed for an entry.

The number of days of advancing warning, i.e. to trigger the Yellow notification, is customizable by 
the user (see "Options | Preferences").

The displaying of this field may be turned off by the user in the Show Fields function (see "Options | 
Show Fields").



Name Field
This is a freeform text field for use, by default, to specify a persons Name. 

Smart Address requires either this field or the Company field to be completed for any entry.

Smart Address allows the use and label of this field to be customized by the user.



Notes Field
This is a freeform text field for use, by default, to enter notes on the person or company concerned.

Smart Address allows the use and label of this field to be customized by the user.



Reminder Notification Marker
Smart Address will indicate when an entry has a date due by checking the Reminder Frequency and 
it's associated date. If that date falls within the notification period set, then a Notification Marker will 
be placed against the date concerned. 

Smart Address can, if required, also place a Notification Marker against the entry within the Index 
List.



Telephone Numbers
These are four freeform text fields for use, by default, to specify up to four telephone numbers for the
person or company concerned.

It should be noted that these fields can also be used to store non-telephone numbers, for example 
Electronic Mail addresses, product codes, etc.

Smart Address allows the use and label of these fields to be customized by the user.



Position Field
This is a freeform text field for use, by default, to specify the persons position within a Company. For 
example, Vice President, Managing Director, etc.

Smart Address allows the use and label of this field to be customized by the user.



Reminder Frequency
This field is a drop-down list box, that allows a reminder frequency to be associated with a date.    
Selecting the drop-down arrow, will display a list box containing a selection of reminder frequencies 
that may be set.

Once a Reminder is acknowledged (see "Tools | Acknowledge Reminder"), Smart Address will 
advance the associated date by the Reminder Frequency specified. For example, if the frequency is 
set as a four weekly reminder, then the associated date will be advanced by four weeks.



Title Field
This is a freeform text field for use, by default, to specify a persons 'Title'. For example, Mr, Mrs, 
Doctor, etc.

Smart Address allows the use and label of this field to be customized by the user.



Spare Fields
The 'Others' tab contains six freeform text fields that are by default labeled "User Definable 1 - 6". 
These fields do not have any defined use and may be used to hold additional information about the 
entry.

For example, one of the fields may be used as a Christmas card checklist. To do this, label the field 
as "Send Christmas Card" and enter the word "Yes" for any entries that require a card sending. 
When it's time to send your Christmas cards, you can perform a search against just the "Send 
Christmas Card" field for any entries that contain "Yes" in this field.

Smart Address allows the use and labels of these fields to be customized by the user.



"Active Reminder"
An Active Reminder is where a date within an entry has a reminder set and that reminder has now 
become due.



"Data Page"
The Data Page is the insert area to the right of the Index List that contains the entry's data within four 
tabbed pages.



"Index Criteria"
The Index Criteria is the criteria used to restrict the entries displayed within the Index List. The criteria in 
effect is shown within the Status Bar at the bottom of the Smart Address application. The Index Criteria 
may be set by use of the Index, Search or Show.. commands found under the "Tools" menu.



"Index List"
The Index List is the area on the left hand side of an Address Book, that lists the entries matching the 
current Index Criteria. An entry's data, may be displayed by selecting it's Index from this list.



"Tag"
If an Entry has been "Tagged", then the entry's Tag state will be set.



"Tagged"
An Entry's "tagged" state can be toggled by use of the "Tools | Tag Entry" command. Tagged entries are 
indicated in Red within the Index List.



All Words
This means that the Index Character is matched against the first character of every word of each entry's 
Index Field. If and of these are the same, then that entry is added to the Index List



First Word
This means that the Index Character is matched against the first character of the first word of each 
entry's Index Field. If these are the same then that entry is added to the Index List.



Index Category
The Index Category is used for restricting entries within the Index List. This is set via the "Set Display 
Index" command of the Tools Menu.



Index Character
The Character used for restricting entries within the Index List. This is set via the "Set Display Index" 
command of the Tools Menu.



Index Criteria
The Index Criteria is the criteria used to restrict the entries displayed within the Index List. The criteria in 
effect is shown within the Status Bar at the bottom of the Smart Address application. The Index Criteria 
may be set by use of the Index, Search or Show.. commands found under the "Tools" menu.



Index Field
The Index Field is the field whose content is used to Index that entry on. By default this is the Name 
field, but this may be changed by using either the 'Default Index' facility within the Preferences Menu, or 
by selecting a different Index Field via the Entry's "Others" Tab.



Index Order
The Index Order is the order that entries are displayed within the Index List. This order is dependent on 
the current "Indexed On" value set by the Set Display Index Command of the Tools menu. If the value is 
set to "Last Word", then the Index List will be sorted on the last word of each entry's Index Field. 
Otherwise, the Index List will be sorted on the first word of each entry's Index Field.



Last Word
This means that the Index Character is matched against the first character of the last word of each 
entry's Index Field. If these are the same then that entry is added to the Index List



New Entry Mode
New Entry Mode is when Smart Address has been asked to create a new entry. In this mode, the Index 
List is disabled and all fields within the "Data Page" are cleared allowing the new data to be entered.



Status Bar
The Status Bar is the area at the bottom of the main Smart Address Application Window and is used to 
provide various feedback to the user regarding the current state of Smart Address.



Update Entry Mode
In this mode, the Index List is disabled and the fields within the "Data Page" are enabled to allow 
updating of the Entry's data.






